p PatchFirst

PatchFirst · Latest vulnerabilities

silverstripe/admin vulnerabilities

Vulnerabilities published for silverstripe/admin in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2023-49783

    Medium · CVSS 4.3EPSS 0.34%Fix available

    No permission checks for editing/deleting records with CSV import form

    Silverstripe Admin provides a basic management interface for the Silverstripe Framework. In versions on the 1.x branch prior to 1.13.19 and on the 2.x branch prior to 2.1.8, users who don't have edit or delete permissions for records exposed in a `ModelAdmin` can still edit or delete records using the CSV import form, provided they have create permissions. The likelihood of a user having create permissions but not having edit or delete permissions is low, but it is possible. Note that this doesn't affect any `ModelAdmin` which has had the import form disabled via the `showImportForm` public property. Versions 1.13.19 and 2.1.8 contain a patch

    • Update to 1.13.19
    • Update to 2.1.8
    Published Updated
  2. GHSA-jxcx-3h54-qqxx

    Not ratedFix available

    SilverStripe CMS Cross-site Scripting vulnerabilities inherited from TinyMCE

    TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting silverstripe/admin. Only Silverstripe CMS 4 is affected by these vulnerabilities. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in silverstripe/admin. Silverstripe CMS 5 is not affected by these vulnerabilities because it uses TinyMCE 6.

    • Update to 1.13.6
    Published Updated
  3. GHSA-4q66-g4mm-8rg5

    Medium · CVSS 5.4Fix available

    Silverstripe has Cross-site Scripting (XSS) vulnerabilities inherited from TinyMCE

    TinyMCE 4.x is vulnerable to several XSS vectors, which had been patched in later versions. Two of these have been identified as affecting `silverstripe/admin`. Only Silverstripe CMS 4 is affected by this issue. It's not possible to upgrade Silverstripe CMS 4 to use a more recent release of TinyMCE without introducing breaking changes. Instead, the security patches that shipped in later releases of TinyMCE have been backported to the TinyMCE version bundled in `silverstripe/admin`. Silverstripe CMS 5 is not affected by those vulnerabilities because it uses TinyMCE 6. You can find more information about the underlying vulnerabilities in tho

    • Update to 1.13.6
    Published Updated
  4. GHSA-wqm8-jx8r-8rcq

    Medium · CVSS 5.4Fix available

    Cross-site scripting vulnerabilities in old version of bundled TinyMCE

    An old version of TinyMCE include an XSS vulnerability, which was patched in a later version. This was described by TinyMCE: > A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower. We reviewed the potential impact of this vulnerability within the context of Silverstripe CMS. We concluded this is a medium impact vulnerability given how TinyMCE is used by Silverstripe CMS. Reported

    • Update to 1.12.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →