p PatchFirst

PatchFirst · Latest vulnerabilities

ansible vulnerabilities · Page 4

Vulnerabilities published for ansible in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 68

  1. CVE-2016-9587

    Medium · CVSS 6.6EPSS 17.14%Public exploitFix available

    CVE-2016-9587

    Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

    • Update to 2.1.4.0
    • Update to 2.2.1.0
    Published Updated
  2. CVE-2017-7550

    Critical · CVSS 9.8EPSS 3.56%Fix available

    CVE-2017-7550

    A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

    • Update to 2.3.3.0
    • Update to 2.4.1.0
    Published Updated
  3. CVE-2016-3096

    High · CVSS 8.5EPSS 0.47%Fix available

    CVE-2016-3096

    The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /opt/.lxc-attach-script, (2) the archived container in the archive_path directory, or the (3) lxc-attach-script.log or (4) lxc-attach-script.err files in the temporary directory.

    • Update to 1.9.6.1
    • Update to 2.0.2.0
    Published Updated
  4. CVE-2015-3908

    High · CVSS 8.7EPSS 0.95%Fix available

    CVE-2015-3908

    Ansible before 1.9.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.

    • Update to 1.9.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →