p PatchFirst

PatchFirst · Latest vulnerabilities

apache-superset vulnerabilities · Page 4

Vulnerabilities published for apache-superset in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 66

  1. CVE-2021-27907

    Medium · CVSS 5.4EPSS 86.39%Fix available

    Apache Superset stored XSS on Dashboard markdown

    Apache Superset up to and including 0.38.0 allowed the creation of a Markdown component on a Dashboard page for describing chart's related information. Abusing this functionality, a malicious user could inject javascript code executing unwanted action in the context of the user's browser. The javascript code will be automatically executed (Stored XSS) when a legitimate user surfs on the dashboard page. The vulnerability is exploitable creating a “div” section and embedding in it a “svg” element with javascript code.

    • Update to 0.38.1
    Published Updated
  2. CVE-2020-13952

    High · CVSS 8.6EPSS 2.02%Fix available

    CVE-2020-13952

    In the course of work on the open source project it was discovered that authenticated users running queries against Hive and Presto database engines could access information via a number of templated fields including the contents of query description metadata database, the hashed version of the authenticated users’ password, and access to connection information including the plaintext password for the current connection. It would also be possible to run arbitrary methods on the database connection object for the Presto or Hive connection, allowing the user to bypass security controls internal to Superset. This vulnerability is present in ever

    • Update to 0.37.2
    Published Updated
  3. CVE-2020-13948

    High · CVSS 8.8EPSS 3.1%Fix available

    CVE-2020-13948

    While investigating a bug report on Apache Superset, it was determined that an authenticated user could craft requests via a number of templated text fields in the product that would allow arbitrary access to Python’s `os` package in the web application process in versions < 0.37.1. It was thus possible for an authenticated user to list and access files, environment variables, and process information. Additionally it was possible to set environment variables for the current process, create and update files in folders writable by the web process, and execute arbitrary programs accessible by the web process. All other operations available to th

    • Update to 0.37.1
    Published Updated
  4. CVE-2020-1932

    Medium · CVSS 6.5EPSS 1.35%Fix available

    CVE-2020-1932

    An information disclosure issue was found in Apache Superset 0.34.0, 0.34.1, 0.35.0, and 0.35.1. Authenticated Apache Superset users are able to retrieve other users' information, including hashed passwords, by accessing an unused and undocumented API endpoint on Apache Superset.

    • Update to 0.35.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →