p PatchFirst

PatchFirst · Latest vulnerabilities

apache-superset vulnerabilities · Page 3

Vulnerabilities published for apache-superset in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 66

  1. CVE-2023-27524

    High · CVSS 8.9EPSS 98.15%In KEVPublic exploitFix available

    Apache Superset: Session validation vulnerability when using provided default SECRET_KEY

    Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config. All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database. Add a strong SECRET_KEY to your `superset_config.py` file like: SECRET_KEY = <YOUR_OWN

    • Update to 2.1.0
    Published Updated
  2. CVE-2023-25504

    Medium · CVSS 4.9EPSS 0.96%Fix available

    Apache Superset: Possible SSRF on import datasets

    A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed. This vulnerability exists in Apache Superset versions up to and including 2.0.1.

    • Update to 2.1.0
    Published Updated
  3. CVE-2022-41703

    Medium · CVSS 5.4EPSS 1.24%Fix available

    Apache Superset: SQL injection vulnerability in adhoc clauses

    A vulnerability in the SQL Alchemy connector of Apache Superset allows an authenticated user with read access to a specific database to add subqueries to the WHERE and HAVING fields referencing tables on the same database that the user should not have access to, despite the user having the feature flag "ALLOW_ADHOC_SUBQUERY" disabled (default value). This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

    • Update to 1.5.3
    • Update to 2.0.1
    Published Updated
  4. CVE-2022-45438

    Medium · CVSS 5.3EPSS 1.27%Fix available

    Apache Superset: Dashboard metadata information leak

    When explicitly enabling the feature flag DASHBOARD_CACHE (disabled by default), the system allowed for an unauthenticated user to access dashboard configuration metadata using a REST API Get endpoint. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

    • Update to 1.5.3
    • Update to 2.0.1
    Published Updated
  5. CVE-2022-43721

    Medium · CVSS 5.4EPSS 1.03%Fix available

    Apache Superset: Open Redirect Vulnerability

    An authenticated attacker with update datasets permission could change a dataset link to an untrusted site, users could be redirected to this site when clicking on that specific dataset. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

    • Update to 1.5.3
    • Update to 2.0.1
    Published Updated
  6. CVE-2022-43720

    Medium · CVSS 5.4EPSS 1.29%Fix available

    Apache Superset: Improper rendering of user input

    An authenticated attacker with write CSS template permissions can create a record with specific HTML tags that will not get properly escaped by the toast message displayed when a user deletes that specific CSS template record. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

    • Update to 1.5.3
    • Update to 2.0.1
    Published Updated
  7. CVE-2022-43718

    Medium · CVSS 5.4EPSS 1.17%Fix available

    Apache Superset: Cross-Site Scripting vulnerability on upload forms

    Upload data forms do not correctly render user input leading to possible XSS attack vectors that can be performed by authenticated users with database connection update permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

    • Update to 1.5.3
    • Update to 2.0.1
    Published Updated
  8. CVE-2022-43717

    Medium · CVSS 5.4EPSS 1.29%Fix available

    Apache Superset: Cross-Site Scripting on dashboards

    Dashboard rendering does not sufficiently sanitize the content of markdown components leading to possible XSS attack vectors that can be performed by authenticated users with create dashboard permissions. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.

    • Update to 1.5.3
    • Update to 2.0.1
    Published Updated
  9. CVE-2021-37839

    Medium · CVSS 4.3EPSS 1.37%Fix available

    Improper access to dataset metadata information

    Apache Superset up to 1.5.1 allowed for authenticated users to access metadata information related to datasets they have no permission on. This metadata included the dataset name, columns and metrics.

    • Update to 1.5.1
    Published Updated
  10. CVE-2021-44451

    High · CVSS 7.1EPSS 7.86%Public exploitFix available

    API sensitive information leak

    Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.

    • Update to 1.4.0
    Published Updated
  11. CVE-2021-41971

    High · CVSS 8.8EPSS 1.76%Fix available

    Possible SQL Injection when template processing is enabled

    Apache Superset up to and including 1.3.0 when configured with ENABLE_TEMPLATE_PROCESSING on (disabled by default) allowed SQL injection when a malicious authenticated user sends an http request with a custom URL.

    • Update to 1.3.1
    Published Updated
  12. CVE-2021-32609

    Medium · CVSS 5.4EPSS 1.65%Fix available

    XSS vulnerability on Explore page

    Apache Superset up to and including 1.1 does not sanitize titles correctly on the Explore page. This allows an attacker with Explore access to save a chart with a malicious title, injecting html (including scripts) into the page.

    • Update to 1.2.0
    Published Updated
  13. CVE-2021-28125

    Medium · CVSS 6.1EPSS 64.02%Fix available

    Apache Superset Open Redirect

    Apache Superset up to and including 1.0.1 allowed for the creation of an external URL that could be malicious. By not checking user input for open redirects the URL shortener functionality would allow for a malicious user to create a short URL for a dashboard that could convince the user to click the link.

    • Update to 1.1.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →