p PatchFirst

PatchFirst · Latest vulnerabilities

document-merge-service vulnerabilities

Vulnerabilities published for document-merge-service in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-53964

    High · CVSS 7.2EPSS 0.49%Fix available

    Document Merge Service vulnerable to RCE via SSTI (xlsx tempaltes)

    Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Prior to version 9.1.0, a remote code execution (RCE) via server-side template injection (SSTI) allows for user supplied code to be executed in the server's context where it is executed as the document-merge-server user with the UID 901 thus giving an attacker considerable control over the container. The vulnerability is limited to XLSX templates, were the xltpl library uses a npn-sandboxed Jinja environment for the processing of the template. This issue has been patched in version 9.1.0.

    • Update to 9.1.0
    Published Updated
  2. CVE-2024-37301

    High · CVSS 7.2EPSS 1.04%Fix available

    document-merge-service vulnerable to Remote Code Execution via Server-Side Template Injection

    Document Merge Service is a document template merge service providing an API to manage templates and merge them with given data. Versions 6.5.1 and prior are vulnerable to remote code execution via server-side template injection which, when executed as root, can result in full takeover of the affected system. As of time of publication, no patched version exists, nor have any known workarounds been disclosed.

    • Update to 6.5.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →