p PatchFirst

PatchFirst · Latest vulnerabilities

flask-security-too vulnerabilities

Vulnerabilities published for flask-security-too in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2026-46715

    Medium · CVSS 5.3EPSS 0.35%Fix available

    Flask-Security-Too OAuth reauthentication freshness bypass via cross- user OAuth identity acceptance

    Flask-Security-Too allows users to add security features to their Flask applicationa. Version 5.8.0's OAuth reauthentication flow can mark a session as fresh after verifying an OAuth account that belongs to a different user. If an attacker can operate an already-authenticated but stale victim session, they can complete OAuth verification using their own OAuth identity. The victim session is then treated as recently reauthenticated, allowing freshness-protected account actions to proceed. Version 5.8.1 contains a fix for this issue.

    • Update to 5.8.1
    Published Updated
  2. GHSA-f66q-9rf6-8795

    Medium · CVSS 5.3No fix published

    Flask-Security-Too: WebAuthn reauthentication freshness bypass via cross-user assertion

    ### Summary Flask-Security-Too 5.8.0 and 5.8.1 mark a session as reauthentication-fresh after processing a WebAuthn assertion whose proven credential belongs to a different user than the currently authenticated session user. The check that `GHSA-97r5-pg8x-p63p` added on the OAuth reauthentication path (`user.email == current_user.email`) is missing on the WebAuthn reauthentication path. An attacker who owns any WebAuthn credential registered to any account on the deployment can satisfy a victim session's freshness gate by submitting their own WebAuthn proof into the victim session. ### Affected versions `Flask-Security-Too` `>= 5.8.0, <= 5

    Published Updated
  3. CVE-2021-32618

    Low · CVSS 3.1EPSS 2.84%Public exploitFix available

    Open Redirect Vulnerability

    The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is an independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. All versions of Flask-Security-Too allow redirects after many successful views (e.g. /login) by honoring the ?next query param. There is code in FS to validate that the url specified in the next parameter is either relative OR has the same netloc (network location) as the requesting URL. This check utilizes Pythons urlsplit library. However many browsers are very lenient on the kind of URL they accept and 'fill in the blanks' when

    • Update to 4.1.0
    Published Updated
  4. GHSA-fxq4-r6mr-9x64

    Not ratedFix available

    CSRF Vuln can expose user's QRcode

    ### Impact When a user is setting up two-factor authentication using an authenticator app, a QRcode is generated and made available via a GET request to /tf-qrcode. Since GETs do not have any CSRF protection, it is possible a malicious 3rd party could access the QRcode and therefore gain access to two-factor authentication codes. Note that the /tf-qrcode endpoint is ONLY accessible while the user is initially setting up their device. Once setup is complete, there is no vulnerability. ### Patches This is fixed in the upcoming 4.0.0 release. ### Workarounds You can provide your own URL for fetching the QRcode by defining SECURITY_TWO_FACTOR_Q

    • Update to 3.4.5
    Published Updated
  5. CVE-2021-21241

    High · CVSS 7.4EPSS 0.93%Fix available

    CSRF can expose users authentication token in Flask-Security-Too

    The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is a independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. In Flask-Security-Too from version 3.3.0 and before version 3.4.5, the /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token. Version 3.4.5 and version 4.0.0 are patched. As a workaround, if you aren't using authentication tokens - you c

    • Update to 3.4.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →