p PatchFirst

PatchFirst · Latest vulnerabilities

pgadmin4 vulnerabilities · Page 2

Vulnerabilities published for pgadmin4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2024-4215

    High · CVSS 7.4EPSS 0.63%Fix available

    The Multi Factor Authentication bypass vulnerability in pgAdmin 4

    pgAdmin <= 8.5 is affected by a multi-factor authentication bypass vulnerability. This vulnerability allows an attacker with knowledge of a legitimate account’s username and password may authenticate to the application and perform sensitive actions within the application, such as managing files and executing SQL queries, regardless of the account’s MFA enrollment status.

    • Update to 8.6
    Published Updated
  2. CVE-2024-3116

    High · CVSS 7.4EPSS 65.81%Public exploitFix available

    Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4

    pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

    • Update to 8.5
    Published Updated
  3. CVE-2024-2044

    Critical · CVSS 9.9EPSS 79.47%Public exploitFix available

    Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4

    pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.

    • Update to 8.4
    Published Updated
  4. CVE-2023-5002

    Medium · CVSS 6EPSS 1.78%Fix available

    Pgadmin4: remote code execution by an authenticated user

    A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.6 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.

    • Update to 7.7
    Published Updated
  5. CVE-2022-4223

    High · CVSS 8.8EPSS 80.07%Public exploitFix available

    CVE-2022-4223

    The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.

    • Update to 6.17
    Published Updated
  6. CVE-2022-0959

    Medium · CVSS 6.5EPSS 0.97%Fix available

    CVE-2022-0959

    A malicious, but authorised and authenticated user can construct an HTTP request using their existing CSRF token and session cookie to manually upload files to any location that the operating system user account under which pgAdmin is running has permission to write.

    • Update to 6.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →