p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 149

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. GHSA-gwfx-p7mr-f92v

    Critical · CVSS 9Fix available

    Missing Access Check in TYPO3 CMS

    Extbase request handling fails to implement a proper access check for requested controller/ action combinations, which makes it possible for an attacker to execute arbitrary Extbase actions by crafting a special request. To successfully exploit this vulnerability, an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation. The missing access check inevitably leads to information disclosure or remote code execution, depending on the action that an attacker is able to execute.

    • Update to 6.2.25
    • Update to 7.6.8
    • Update to 8.1.1
    Published Updated
  2. GHSA-v5jp-4h2p-j2p4

    Medium · CVSS 6.5Fix available

    Privilege Escalation in TYPO3 CMS

    The workspace/ version preview link created by a privileged (backend) user could be abused to obtain certain editing permission, if the admin panel is configured to be shown. A valid preview link is required to exploit this vulnerability.

    • Update to 6.2.20
    • Update to 7.6.5
    • Update to 8.0.1
    Published Updated
  3. GHSA-6xh8-8pfv-53vx

    Medium · CVSS 5.4Fix available

    Authentication Bypass in TYPO3 CMS

    The default authentication service misses to invalidate empty strings as password. Therefore it is possible to authenticate backend and frontend users without password set in the database. Note: TYPO3 does not allow to create user accounts without a password. Your TYPO3 installation might only be affected if there is a third party component creating user accounts without password by directly manipulating the database.

    • Update to 6.2.20
    • Update to 7.6.5
    • Update to 8.0.1
    Published Updated
  4. GHSA-jmh9-6rjq-gjh9

    Not ratedFix available

    Vulnerable embedded jQuery Version

    ### Summary PIMCore uses the JavaScript library jQuery in version 3.4.1. This version is vulnerable to cross-site-scripting (XSS). ### Details In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing elements from untrusted sources - even after sanitizing it to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0. Publish Date: 2020-04-29 URL:= https://security.snyk.io/package/npm/jquery/3.4.1

    • Update to 1.4.3
    Published Updated
  5. GHSA-qffc-gwpp-m2xr

    Not ratedFix available

    XML External Entity (XXE) Processing in TYPO3 Core

    All XML processing within the TYPO3 CMS are vulnerable to XEE processing. This can lead to load internal and/or external (file) content within an XML structure. Furthermore it is possible to inject arbitrary files for an XML Denial of Service attack. For more information on that topic see https://www.owasp.org/index.php/XML_External_Entity_(XXE)_Processing.

    • Update to 6.2.19
    • Update to 7.6.4
    Published Updated
  6. CVE-2024-32871

    High · CVSS 7.5EPSS 0.76%Fix available

    Pimcore Vulnerable to Flooding Server with Thumbnail files

    Pimcore is an Open Source Data & Experience Management Platform. The Pimcore thumbnail generation can be used to flood the server with large files. By changing the file extension or scaling factor of the requested thumbnail, attackers can create files that are much larger in file size than the original. This vulnerability is fixed in 11.2.4.

    • Update to 11.2.4
    Published Updated
  7. GHSA-cg4m-qjjp-7497

    Not ratedFix available

    TYPO3 Cross-Site Scripting in link validator component

    Failing to sanitize content from editors, the link validator component is susceptible to Cross-Site Scripting. A valid editor account with access to content which is scanned by the link validator component is required to exploit this vulnerability.

    • Update to 6.2.18
    • Update to 7.6.3
    Published Updated
  8. GHSA-9895-53fc-98v2

    Not ratedFix available

    TYPO3 SQL Injection in dbal

    A flaw in the database escaping API results in a SQL injection vulnerability when extension dbal is enabled and configured for MySQL passthrough mode in its extension configuration. All queries which use the DatabaseConnection::sql_query are vulnerable, even if arguments were properly escaped with DatabaseConnection::quoteStr beforehand.

    • Update to 6.2.18
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →