p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 193

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-29288

    Medium · CVSS 4.3EPSS 0.65%Fix available

    Adobe Commerce | Incorrect Authorization (CWE-863)

    Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A privileged attacker could leverage this vulnerability to modify a minor functionality of another user's data. Exploitation of this issue does not require user interaction.

    • Update to 2.4.4-p4
    • Update to 2.4.5-p3
    Published Updated
  2. CVE-2023-29287

    Medium · CVSS 5.3EPSS 0.71%Fix available

    Adobe Commerce Information Exposure Security feature bypass

    Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Information Exposure vulnerability that could lead to a security feature bypass. An attacker could leverage this vulnerability to leak minor user data. Exploitation of this issue does not require user interaction..

    • Update to 2.4.4-p4
    • Update to 2.4.5-p3
    Published Updated
  3. CVE-2023-22248

    High · CVSS 7.5EPSS 1.02%Fix available

    Adobe Commerce Incorrect Authorization Security feature bypass

    Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. An attacker could leverage this vulnerability to leak another user's data. Exploitation of this issue does not require user interaction.

    • Update to 2.4.5-p3
    • Update to 2.4.5-p4
    Published Updated
  4. CVE-2023-34448

    High · CVSS 8.8EPSS 4.52%Fix available

    Grav Server-side Template Injection (SSTI) via Twig Default Filters

    Grav is a flat-file content management system. Prior to version 1.7.42, the patch for CVE-2022-2073, a server-side template injection vulnerability in Grav leveraging the default `filter()` function, did not block other built-in functions exposed by Twig's Core Extension that could be used to invoke arbitrary unsafe functions, thereby allowing for remote code execution. A patch in version 1.74.2 overrides the built-in Twig `map()` and `reduce()` filter functions in `system/src/Grav/Common/Twig/Extension/GravExtension.php` to validate the argument passed to the filter in `$arrow`.

    • Update to 1.7.42
    Published Updated
  5. CVE-2023-34253

    High · CVSS 8.8EPSS 2.07%Fix available

    Grav vulnerable to Server-side Template Injection (SSTI) via Denylist Bypass

    Grav is a flat-file content management system. Prior to version 1.7.42, the denylist introduced in commit 9d6a2d to prevent dangerous functions from being executed via injection of malicious templates was insufficient and could be easily subverted in multiple ways -- (1) using unsafe functions that are not banned, (2) using capitalised callable names, and (3) using fully-qualified names for referencing callables. Consequently, a low privileged attacker with login access to Grav Admin panel and page creation/update permissions is able to inject malicious templates to obtain remote code execution. A patch in version 1.7.42 improves the denylist

    • Update to 1.7.42
    Published Updated
  6. CVE-2023-34252

    High · CVSS 8.8EPSS 2.07%Fix available

    Grav Server-side Template Injection via Insufficient Validation in filterFilter

    Grav is a flat-file content management system. Prior to version 1.7.42, there is a logic flaw in the `GravExtension.filterFilter()` function whereby validation against a denylist of unsafe functions is only performed when the argument passed to filter is a string. However, passing an array as a callable argument allows the validation check to be skipped. Consequently, a low privileged attacker with login access to Grav Admin panel and page creation/update permissions is able to inject malicious templates to obtain remote code execution. The vulnerability can be found in the `GravExtension.filterFilter()` function declared in `/system/src/Grav

    • Update to 1.7.42
    Published Updated
  7. CVE-2023-34251

    Critical · CVSS 10EPSS 2.34%Fix available

    Grav Server Side Template Injection vulnerability

    Grav is a flat-file content management system. Versions prior to 1.7.42 are vulnerable to server side template injection. Remote code execution is possible by embedding malicious PHP code on the administrator screen by a user with page editing privileges. Version 1.7.42 contains a fix for this issue.

    • Update to 1.7.42
    Published Updated
  8. DRUPAL-CONTRIB-2023-020

    Not ratedFix available

    DRUPAL-CONTRIB-2023-020

    This module enables you to define a 'weekly office hours' field type, and add a field to any Content type, in order to display the weekly opening hours for a location. The module doesn't sufficiently filter user-supplied text leading to a Cross Site Scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker needs additional permissions. The vulnerability can be exploited by an attacker with a role with the permission "administer display" regardless of other configurations. In some scenarios, the vulnerability can be exploited by a user with "Create content" or "Edit content" for a relevant Content type.

    • Update to 1.11.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →