p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 194

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. DRUPAL-CONTRIB-2023-019

    Not ratedFix available

    DRUPAL-CONTRIB-2023-019

    This module provides social media share & follow buttons. The module doesn't sufficiently restrict AddToAny block settings to users who have permission to administer AddToAny. This allows users with lower permission to configure malicious code leading to a Cross Site Scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer blocks".

    • Update to 1.21.0
    • Update to 2.0.4
    Published Updated
  2. DRUPAL-CONTRIB-2023-018

    Not ratedFix available

    DRUPAL-CONTRIB-2023-018

    This module provides social media share & follow buttons. The module doesn't sufficiently check access to a node when retrieving the label of an AddToAny block. This vulnerability is mitigated by the fact it requires the node ID to be passed via the route, requiring another module or specific configuration to provide this ID, as the /node/{id} page doesn't provide this value on an access denied.

    • Update to 1.21.0
    • Update to 2.0.4
    Published Updated
  3. DRUPAL-CONTRIB-2023-017

    Not ratedFix available

    DRUPAL-CONTRIB-2023-017

    The Consent Popup provides a configurable popup that requires acceptance of a question before the visitor can continue, typically used for age consent. The module doesn't sufficiently sanitizes the text on the block leading to a cross site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with the permission to create blocks.

    • Update to 1.0.3
    Published Updated
  4. DRUPAL-CONTRIB-2023-016

    Not ratedFix available

    DRUPAL-CONTRIB-2023-016

    The Iubenda Integration module provides a custom block to provide a link to the Iubenda privacy policy. On this block, a custom prefix and suffix text can be entered. The module does not sufficiently filter the block text fields on output, resulting in a Cross-Site Scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with permission to use the layout builder on content, edit the layout, or with the "Administer blocks" permission.

    • Update to 4.0.1
    Published Updated
  5. CVE-2023-32692

    Critical · CVSS 9.8EPSS 1.13%Fix available

    Remote Code Execution Vulnerability in Validation Placeholders

    CodeIgniter is a PHP full-stack web framework. This vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders. The vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally. This issue is patched in version 4.3.5.

    • Update to 4.3.5
    Published Updated
  6. CVE-2023-33194

    Low · CVSS 3.7EPSS 0.62%Fix available

    CraftCMS stored XSS in Quick Post widget error message

    Craft is a CMS for creating custom digital experiences on the web.The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload. Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save. This issue was patched in version 4.4.6.

    • Update to 3.8.6
    • Update to 4.4.6
    Published Updated
  7. CVE-2023-2817

    Medium · CVSS 5.4EPSS 0.44%Fix available

    CVE-2023-2817

    A post-authentication stored cross-site scripting vulnerability exists in Craft CMS versions <= 4.4.11. HTML, including script tags can be injected into field names which, when the field is added to a category or section, will trigger when users visit the Categories or Entries pages respectively.

    • Update to 4.4.12
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →