SUSE-SU-2024:1539-1
SUSE-SU-2024:1539-1 · Security update for bouncycastle
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This update for bouncycastle fixes the following issues: Update to version 1.78.1, including fixes for: - CVE-2024-30171: Fixed timing side-channel attacks against RSA decryption (both PKCS#1v1.5 and OAEP). (bsc#1223252)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
bouncycastle SUSE:Linux Enterprise Module for Development Tools 15 SP5
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise Server 15 SP2-LTSS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise Server 15 SP3-LTSS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise Server 15 SP4-LTSS
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle SUSE:Enterprise Storage 7.1
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1
bouncycastle openSUSE:Leap 15.5
- Affected ranges
- ECOSYSTEM: < 1.78.1-150200.3.29.1
Update to 1.78.1-150200.3.29.1