p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 3

Vulnerabilities published for ghostscript in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 54

  1. USN-3272-2

    Not ratedFix available

    ghostscript regression

    USN-3272-1 fixed vulnerabilities in Ghostscript. This change introduced a regression when the DELAYBIND feature is used with the eqproc command. This update fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that Ghostscript improperly handled parameters to the rsdparams and eqproc commands. An attacker could use these to craft a malicious document that could disable -dSAFER protections, thereby allowing the execution of arbitrary code, or cause a denial of service (application crash). (CVE-2017-8291) Kamil Frankowicz discovered a use-after-free vulnerability in the color management

    • Update to 9.10~dfsg-0ubuntu10.9
    Published Updated
  2. CVE-2017-8291

    High · CVSS 7.8EPSS 96.97%In KEVPublic exploitFix available

    CVE-2017-8291

    Artifex Ghostscript through 2017-04-26 allows -dSAFER bypass and remote command execution via .rsdparams type confusion with a "/OutputFile (%pipe%" substring in a crafted .eps document that is an input to the gs program, as exploited in the wild in April 2017.

    • Update to 9.10~dfsg-0ubuntu10.7
    Published Updated
  3. CVE-2016-10317

    High · CVSS 7.8EPSS 2.28%Fix available

    CVE-2016-10317

    The fill_threshhold_buffer function in base/gxht_thresh.c in Artifex Software, Inc. Ghostscript 9.20 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted PostScript document.

    • Update to 9.10~dfsg-0ubuntu10.12
    Published Updated
  4. CVE-2016-10220

    Medium · CVSS 5.5EPSS 1.94%Fix available

    CVE-2016-10220

    The gs_makewordimagedevice function in base/gsdevmem.c in Artifex Software, Inc. Ghostscript 9.20 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted file that is mishandled in the PDF Transparency module.

    • Update to 9.10~dfsg-0ubuntu10.7
    Published Updated
  5. CVE-2015-3228

    Not ratedEPSS 3.88%Fix available

    CVE-2015-3228

    Integer overflow in the gs_heap_alloc_bytes function in base/gsmalloc.c in Ghostscript 9.15 and earlier allows remote attackers to cause a denial of service (crash) via a crafted Postscript (ps) file, as demonstrated by using the ps2pdf command, which triggers an out-of-bounds read or write.

    • Update to 9.10~dfsg-0ubuntu10.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →