p PatchFirst

PatchFirst · Latest vulnerabilities

krb5 vulnerabilities · Page 2

Vulnerabilities published for krb5 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2014-5354

    Not ratedEPSS 1.74%Fix available

    CVE-2014-5354

    plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c in MIT Kerberos 5 (aka krb5) 1.12.x and 1.13.x before 1.13.1, when the KDC uses LDAP, allows remote authenticated users to cause a denial of service (NULL pointer dereference and daemon crash) by creating a database entry for a keyless principal, as demonstrated by a kadmin "add_principal -nokey" or "purgekeys -all" command.

    • Update to 1.12+dfsg-2ubuntu5.1
    Published Updated
  2. CVE-2014-5353

    Not ratedEPSS 4.97%Fix available

    CVE-2014-5353

    The krb5_ldap_get_password_policy_from_dn function in plugins/kdb/ldap/libkdb_ldap/ldap_pwd_policy.c in MIT Kerberos 5 (aka krb5) before 1.13.1, when the KDC uses LDAP, allows remote authenticated users to cause a denial of service (daemon crash) via a successful LDAP query with no results, as demonstrated by using an incorrect object type for a password policy.

    • Update to 1.12+dfsg-2ubuntu5.1
    Published Updated
  3. CVE-2014-5351

    Not ratedEPSS 2.62%Fix available

    CVE-2014-5351

    The kadm5_randkey_principal_3 function in lib/kadm5/srv/svr_principal.c in kadmind in MIT Kerberos 5 (aka krb5) before 1.13 sends old keys in a response to a -randkey -keepold request, which allows remote authenticated users to forge tickets by leveraging administrative access.

    • Update to 1.12+dfsg-2ubuntu5.1
    Published Updated
  4. CVE-2014-4345

    Not ratedEPSS 8.09%Fix available

    CVE-2014-4345

    Off-by-one error in the krb5_encode_krbsecretkey function in plugins/kdb/ldap/libkdb_ldap/ldap_principal2.c in the LDAP KDB module in kadmind in MIT Kerberos 5 (aka krb5) 1.6.x through 1.11.x before 1.11.6 and 1.12.x before 1.12.2 allows remote authenticated users to cause a denial of service (buffer overflow) or possibly execute arbitrary code via a series of "cpw -keepold" commands.

    • Update to 1.12+dfsg-2ubuntu4.2
    Published Updated
  5. CVE-2014-4344

    Not ratedEPSS 6.61%Fix available

    CVE-2014-4344

    The acc_ctx_cont function in the SPNEGO acceptor in lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) 1.5.x through 1.12.x before 1.12.2 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via an empty continuation token at a certain point during a SPNEGO negotiation.

    • Update to 1.12+dfsg-2ubuntu4.2
    Published Updated
  6. CVE-2014-4343

    Not ratedEPSS 6.42%Fix available

    CVE-2014-4343

    Double free vulnerability in the init_ctx_reselect function in the SPNEGO initiator in lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) 1.10.x through 1.12.x before 1.12.2 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via network traffic that appears to come from an intended acceptor, but specifies a security mechanism different from the one proposed by the initiator.

    • Update to 1.12+dfsg-2ubuntu4.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →