p PatchFirst

PatchFirst · Latest vulnerabilities

firefox vulnerabilities · Page 19

Vulnerabilities published for firefox in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 691

  1. CVE-2018-5159

    Critical · CVSS 9.8EPSS 20.64%Public exploitFix available

    CVE-2018-5159

    An integer overflow can occur in the Skia library due to 32-bit integer use in an array without integer overflow checks, resulting in possible out-of-bounds writes. This could lead to a potentially exploitable crash triggerable by web content. This vulnerability affects Thunderbird < 52.8, Thunderbird ESR < 52.8, Firefox < 60, and Firefox ESR < 52.8.

    • Update to 60.0+build2-0ubuntu0.16.04.1
    Published Updated
  2. CVE-2018-5158

    High · CVSS 8.8EPSS 10.24%Fix available

    CVE-2018-5158

    The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8 and Firefox < 60.

    • Update to 60.0+build2-0ubuntu0.16.04.1
    Published Updated
  3. CVE-2018-5157

    High · CVSS 7.5EPSS 1.58%Fix available

    CVE-2018-5157

    Same-origin protections for the PDF viewer can be bypassed, allowing a malicious site to intercept messages meant for the viewer. This could allow the site to retrieve PDF files restricted to viewing by an authenticated user on a third-party website. This vulnerability affects Firefox ESR < 52.8 and Firefox < 60.

    • Update to 60.0+build2-0ubuntu0.16.04.1
    Published Updated
  4. CVE-2018-5154

    Critical · CVSS 9.8EPSS 3.19%Fix available

    CVE-2018-5154

    A use-after-free vulnerability can occur while enumerating attributes during SVG animations with clip paths. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 52.8, Thunderbird ESR < 52.8, Firefox < 60, and Firefox ESR < 52.8.

    • Update to 60.0+build2-0ubuntu0.16.04.1
    Published Updated
  5. CVE-2018-5152

    Medium · CVSS 6.5EPSS 1.6%Fix available

    CVE-2018-5152

    WebExtensions with the appropriate permissions can attach content scripts to Mozilla sites such as accounts.firefox.com and listen to network traffic to the site through the "webRequest" API. For example, this allows for the interception of username and an encrypted password during login to Firefox Accounts. This issue does not expose synchronization traffic directly and is limited to the process of user login to the website and the data displayed to the user once logged in. This vulnerability affects Firefox < 60.

    • Update to 60.0+build2-0ubuntu0.16.04.1
    Published Updated
  6. CVE-2018-5150

    Critical · CVSS 9.8EPSS 3.09%Fix available

    CVE-2018-5150

    Memory safety bugs were reported in Firefox 59, Firefox ESR 52.7, and Thunderbird 52.7. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 52.8, Thunderbird ESR < 52.8, Firefox < 60, and Firefox ESR < 52.8.

    • Update to 60.0+build2-0ubuntu0.16.04.1
    Published Updated
  7. CVE-2018-5148

    Critical · CVSS 9.8EPSS 2.92%Fix available

    CVE-2018-5148

    A use-after-free vulnerability can occur in the compositor during certain graphics operations when a raw pointer is used instead of a reference counted one. This results in a potentially exploitable crash. This vulnerability affects Firefox ESR < 52.7.3 and Firefox < 59.0.2.

    • Update to 59.0.2+build1-0ubuntu0.16.04.1
    Published Updated
  8. CVE-2018-5143

    Medium · CVSS 6.1EPSS 0.92%Fix available

    CVE-2018-5143

    URLs using "javascript:" have the protocol removed when pasted into the addressbar to protect users from cross-site scripting (XSS) attacks, but if a tab character is embedded in the "javascript:" URL the protocol is not removed and the script will execute. This could allow users to be socially engineered to run an XSS attack against themselves. This vulnerability affects Firefox < 59.

    • Update to 59.0+build5-0ubuntu0.16.04.1
    Published Updated
  9. CVE-2018-5142

    Medium · CVSS 5.3EPSS 1.19%Fix available

    CVE-2018-5142

    If Media Capture and Streams API permission is requested from documents with "data:" or "blob:" URLs, the permission notifications do not properly display the originating domain. The notification states "Unknown protocol" as the requestee, leading to user confusion about which site is asking for this permission. This vulnerability affects Firefox < 59.

    • Update to 59.0+build5-0ubuntu0.16.04.1
    Published Updated
  10. CVE-2018-5141

    High · CVSS 8.2EPSS 1.55%Fix available

    CVE-2018-5141

    A vulnerability in the notifications Push API where notifications can be sent through service workers by web content without direct user interaction. This could be used to open new tabs in a denial of service (DOS) attack or to display unwanted content from arbitrary URLs to users. This vulnerability affects Firefox < 59.

    • Update to 59.0+build5-0ubuntu0.16.04.1
    Published Updated
  11. CVE-2018-5140

    Medium · CVSS 5.3EPSS 1.27%Fix available

    CVE-2018-5140

    Image for moz-icons can be accessed through the "moz-icon:" protocol through script in web content even when otherwise prohibited. This could allow for information leakage of which applications are associated with specific MIME types by a malicious page. This vulnerability affects Firefox < 59.

    • Update to 59.0+build5-0ubuntu0.16.04.1
    Published Updated
  12. CVE-2018-5137

    High · CVSS 7.5EPSS 1.62%Fix available

    CVE-2018-5137

    A legacy extension's non-contentaccessible, defined resources can be loaded by an arbitrary web page through script. This script does this by using a maliciously crafted path string to reference the resources. Note: this vulnerability does not affect WebExtensions. This vulnerability affects Firefox < 59.

    • Update to 59.0+build5-0ubuntu0.16.04.1
    Published Updated
  13. CVE-2018-5135

    High · CVSS 7.5EPSS 1.5%Fix available

    CVE-2018-5135

    WebExtensions can bypass normal restrictions in some circumstances and use "browser.tabs.executeScript" to inject scripts into contexts where this should not be allowed, such as pages from other WebExtensions or unprivileged "about:" pages. This vulnerability affects Firefox < 59.

    • Update to 59.0+build5-0ubuntu0.16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →