p PatchFirst

PatchFirst · Latest vulnerabilities

libxslt vulnerabilities

Vulnerabilities published for libxslt in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2019-18197

    High · CVSS 7.5EPSS 4.45%Fix available

    CVE-2019-18197

    In xsltCopyText in transform.c in libxslt 1.1.33, a pointer variable isn't reset under certain circumstances. If the relevant memory area happened to be freed and reused in a certain way, a bounds check could fail and memory outside a buffer could be written to, or uninitialized data could be disclosed.

    • Update to 1.1.28-2.1ubuntu0.3
    Published Updated
  2. CVE-2019-13117

    Medium · CVSS 5.3EPSS 6.46%Fix available

    CVE-2019-13117

    In numbers.c in libxslt 1.1.33, an xsl:number with certain format strings could lead to a uninitialized read in xsltNumberFormatInsertNumbers. This could allow an attacker to discern whether a byte on the stack contains the characters A, a, I, i, or 0, or any other character.

    • Update to 1.1.28-2.1ubuntu0.3
    Published Updated
  3. CVE-2017-5029

    High · CVSS 8.8EPSS 2.16%Fix available

    CVE-2017-5029

    The xsltAddTextString function in transform.c in libxslt 1.1.29, as used in Blink in Google Chrome prior to 57.0.2987.98 for Mac, Windows, and Linux and 57.0.2987.108 for Android, lacked a check for integer overflow during a size calculation, which allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page.

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated
  4. CVE-2016-4612

    Not ratedFix available

    UBUNTU-CVE-2016-4612

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2016-1683. Reason: This candidate is a reservation duplicate of CVE-2016-1683. Notes: All CVE users should reference CVE-2016-1683 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated
  5. CVE-2016-4610

    Critical · CVSS 9.8EPSS 4.96%Fix available

    CVE-2016-4610

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4607, CVE-2016-4608, CVE-2016-4609, and CVE-2016-4612.

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated
  6. CVE-2016-4609

    Critical · CVSS 9.8EPSS 5.01%Fix available

    CVE-2016-4609

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4607, CVE-2016-4608, CVE-2016-4610, and CVE-2016-4612.

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated
  7. CVE-2016-4608

    Critical · CVSS 9.8EPSS 4.92%Fix available

    CVE-2016-4608

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4607, CVE-2016-4609, CVE-2016-4610, and CVE-2016-4612.

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated
  8. CVE-2016-4607

    Critical · CVSS 9.8EPSS 4.96%Fix available

    CVE-2016-4607

    libxslt in Apple iOS before 9.3.3, OS X before 10.11.6, iTunes before 12.4.2 on Windows, iCloud before 5.2.1 on Windows, tvOS before 9.2.2, and watchOS before 2.2.2 allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via unknown vectors, a different vulnerability than CVE-2016-4608, CVE-2016-4609, CVE-2016-4610, and CVE-2016-4612.

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated
  9. CVE-2016-1684

    High · CVSS 7.5EPSS 1.84%Fix available

    CVE-2016-1684

    numbers.c in libxslt before 1.1.29, as used in Google Chrome before 51.0.2704.63, mishandles the i format token for xsl:number data, which allows remote attackers to cause a denial of service (integer overflow or resource consumption) or possibly have unspecified other impact via a crafted document.

    • Update to 1.1.28-2.1ubuntu0.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →