p PatchFirst

PatchFirst · Latest vulnerabilities

drupal7 vulnerabilities · Page 2

Vulnerabilities published for drupal7 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 48

  1. CVE-2022-25271

    High · CVSS 7.5EPSS 1.27%No fix published

    CVE-2022-25271

    Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.

    Published Updated
  2. CVE-2020-13672

    Medium · CVSS 6.1EPSS 0.68%No fix published

    CVE-2020-13672

    Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.

    Published Updated
  3. CVE-2020-13662

    Medium · CVSS 6.1EPSS 0.86%No fix published

    CVE-2020-13662

    Open Redirect vulnerability in Drupal Core allows a user to be tricked into visiting a specially crafted link which would redirect them to an arbitrary external URL. This issue affects: Drupal Drupal Core 7 version 7.70 and prior versions.

    Published Updated
  4. CVE-2020-13666

    Medium · CVSS 6.1EPSS 2.93%No fix published

    CVE-2020-13666

    Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

    Published Updated
  5. CVE-2020-13671

    High · CVSS 8.8EPSS 36.17%In KEVFix available

    CVE-2020-13671

    Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting configurations. This issue affects: Drupal Drupal Core 9.0 versions prior to 9.0.8, 8.9 versions prior to 8.9.9, 8.8 versions prior to 8.8.11, and 7 versions prior to 7.74.

    • Update to 7.44-1ubuntu1~16.04.0+esm2
    Published Updated
  6. CVE-2019-6342

    Critical · CVSS 9.8EPSS 2.2%No fix published

    Drupal core - Critical - Access bypass - SA-CORE-2019-008

    An access bypass vulnerability exists when the experimental Workspaces module in Drupal 8 core is enabled. This can be mitigated by disabling the Workspaces module. It does not affect any release other than Drupal 8.7.4.

    Published Updated
  7. CVE-2020-11023

    Medium · CVSS 6.9EPSS 84.89%In KEVPublic exploitFix available

    Potential XSS vulnerability in jQuery

    In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 7.44-1ubuntu1~16.04.0+esm3
    Published Updated
  8. CVE-2020-11022

    Medium · CVSS 6.9EPSS 99.22%Public exploitFix available

    jQuery has a potential XSS vulnerability

    In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

    • Update to 7.44-1ubuntu1~16.04.0+esm3
    Published Updated
  9. CVE-2019-6341

    Medium · CVSS 5.4EPSS 12.19%No fix published

    Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2019-004

    In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

    Published Updated
  10. CVE-2019-6339

    Critical · CVSS 9.8EPSS 35.95%Public exploitNo fix published

    PHAR stream wrapper Arbitrary PHP code execution

    In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

    Published Updated
  11. CVE-2019-6338

    High · CVSS 8EPSS 2.12%No fix published

    third-party PEAR Archive_Tar library updates

    In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

    Published Updated
  12. CVE-2017-6922

    Medium · CVSS 6.5EPSS 1.95%No fix published

    Files uploaded by anonymous users into a private file system can be accessed by other anonymous users

    In Drupal core 8.x prior to 8.3.4 and Drupal core 7.x prior to 7.56; Private files that have been uploaded by an anonymous user but not permanently attached to content on the site should only be visible to the anonymous user that uploaded them, rather than all anonymous users. Drupal core did not previously provide this protection, allowing an access bypass vulnerability to occur. This issue is mitigated by the fact that in order to be affected, the site must allow anonymous users to upload files into a private file system.

    Published Updated
  13. CVE-2018-7602

    High · CVSS 8.1EPSS 99.17%In KEVPublic exploitFix available

    Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004

    A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.

    • Update to 7.44-1ubuntu1~16.04.0+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →