p PatchFirst

PatchFirst · Latest vulnerabilities

moodle vulnerabilities · Page 12

Vulnerabilities published for moodle in the last 30 days: 12. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 323

  1. CVE-2019-14827

    Medium · CVSS 6.1EPSS 0.67%No fix published

    CVE-2019-14827

    A vulnerability was found in Moodle where javaScript injection was possible in some Mustache templates via recursive rendering from contexts. Mustache helper tags that were included in template contexts were not being escaped before that context was injected into another Mustache helper, which could result in script injection in some templates. This affects versions 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions.

    Published Updated
  2. CVE-2019-14831

    Medium · CVSS 6.1EPSS 0.81%No fix published

    CVE-2019-14831

    A vulnerability was found in Moodle 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where forum subscribe link contained an open redirect if forced subscription mode was enabled. If a forum's subscription mode was set to "forced subscription", the forum's subscribe link contained an open redirect.

    Published Updated
  3. CVE-2019-14830

    Medium · CVSS 6.1EPSS 3.3%No fix published

    CVE-2019-14830

    A vulnerability was found in Moodle 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where the mobile launch endpoint contained an open redirect in some circumstances, which could result in a user's mobile access token being exposed. (Note: This does not affect sites with a forced URL scheme configured, mobile service disabled, or where the mobile app login method is "via the app").

    Published Updated
  4. CVE-2019-14828

    Medium · CVSS 4.3EPSS 0.7%No fix published

    CVE-2019-14828

    A vulnerability was found in Moodle affecting 3.7 to 3.7.1, 3.6 to 3.6.5, 3.5 to 3.5.7 and earlier unsupported versions, where users with the capability to create courses were assigned as a teacher in those courses, regardless of whether they had the capability to be automatically assigned that role.

    Published Updated
  5. CVE-2021-20185

    Medium · CVSS 5.3EPSS 1.39%No fix published

    CVE-2021-20185

    It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

    Published Updated
  6. CVE-2020-25629

    High · CVSS 8.8EPSS 1.32%No fix published

    CVE-2020-25629

    A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →