p PatchFirst

PatchFirst · Latest vulnerabilities

bouncycastle vulnerabilities · Page 4

Vulnerabilities published for bouncycastle in the last 30 days: 14. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 65

  1. CVE-2023-33201

    Medium · CVSS 5.3EPSS 0.77%Fix available

    CVE-2023-33201

    Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability. The vulnerability only affects applications that use an LDAP CertStore from Bouncy Castle to validate X.509 certificates. During the certificate validation process, Bouncy Castle inserts the certificate's Subject Name into an LDAP search filter without any escaping, which leads to an LDAP injection vulnerability.

    • Update to 1.59-1ubuntu0.1~esm1
    Published Updated
  2. CVE-2020-15522

    Medium · CVSS 5.9EPSS 1.52%No fix published

    CVE-2020-15522

    Bouncy Castle BC Java before 1.66, BC C# .NET before 1.8.7, BC-FJA before 1.0.1.2, 1.0.2.1, and BC-FNA before 1.0.1.1 have a timing issue within the EC math library that can expose information about the private key when an attacker is able to observe timing information for the generation of multiple deterministic ECDSA signatures.

    Published Updated
  3. CVE-2020-26939

    Medium · CVSS 5.3EPSS 0.92%No fix published

    CVE-2020-26939

    In Legion of the Bouncy Castle BC before 1.61 and BC-FJA before 1.0.1.2, attackers can obtain sensitive information about a private exponent because of Observable Differences in Behavior to Error Inputs. This occurs in org.bouncycastle.crypto.encodings.OAEPEncoding. Sending invalid ciphertext that decrypts to a short payload in the OAEP Decoder could result in the throwing of an early exception, potentially leaking some information about the private exponent of the RSA private key performing the encryption.

    Published Updated
  4. CVE-2018-1000613

    Critical · CVSS 9.8EPSS 4.77%No fix published

    CVE-2018-1000613

    Legion of the Bouncy Castle Legion of the Bouncy Castle Java Cryptography APIs 1.58 up to but not including 1.60 contains a CWE-470: Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in XMSS/XMSS^MT private key deserialization that can result in Deserializing an XMSS/XMSS^MT private key can result in the execution of unexpected code. This attack appear to be exploitable via A handcrafted private key can include references to unexpected classes which will be picked up from the class path for the executing application. This vulnerability appears to have been fixed in 1.60 and later.

    Published Updated
  5. CVE-2018-1000180

    High · CVSS 7.5EPSS 3.42%No fix published

    CVE-2018-1000180

    Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4 and later, BC-FJA 1.0.2 and later.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →