ALPINE-CVE-2025-58098
ALPINE-CVE-2025-58098
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
CVSS 8.3 · High · Fix available
- Published
- Updated
Stack: system
Affected products and versions
apache2 Alpine:v3.20
- Affected ranges
- ECOSYSTEM: < 2.4.66-r0
Update to 2.4.66-r0
apache2 Alpine:v3.21
- Affected ranges
- ECOSYSTEM: < 2.4.66-r0
Update to 2.4.66-r0
apache2 Alpine:v3.22
- Affected ranges
- ECOSYSTEM: < 2.4.66-r0
Update to 2.4.66-r0
apache2 Alpine:v3.23
- Affected ranges
- ECOSYSTEM: < 2.4.66-r0
Update to 2.4.66-r0
apache2 Alpine:v3.24
- Affected ranges
- ECOSYSTEM: < 2.4.66-r0
Update to 2.4.66-r0