p PatchFirst

PatchFirst · Latest vulnerabilities

glib2.0 vulnerabilities · Page 3

Vulnerabilities published for glib2.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 51

  1. CVE-2006-7226

    Not ratedEPSS 1.6%Fix available

    CVE-2006-7226

    Perl-Compatible Regular Expression (PCRE) library before 6.7 does not properly calculate the compiled memory allocation for regular expressions that involve a quantified "subpattern containing a named recursion or subroutine reference," which allows context-dependent attackers to cause a denial of service (error or crash).

    • Update to 2.14.3-1
    Published Updated
  2. CVE-2007-1661

    Not ratedEPSS 2.49%Fix available

    CVE-2007-1661

    Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

    • Update to 2.14.3-1
    Published Updated
  3. CVE-2007-1660

    Not ratedEPSS 4.08%Fix available

    CVE-2007-1660

    Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate sizes for unspecified "multiple forms of character class", which triggers a buffer overflow that allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code.

    • Update to 2.14.3-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →