p PatchFirst

PatchFirst · Latest vulnerabilities

libxml2 vulnerabilities · Page 4

Vulnerabilities published for libxml2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 123

  1. CVE-2017-9048

    High · CVSS 7.5EPSS 4.85%Fix available

    CVE-2017-9048

    libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a stack-based buffer overflow. The function xmlSnprintfElementContent in valid.c is supposed to recursively dump the element content definition into a char buffer 'buf' of size 'size'. At the end of the routine, the function may strcat two more characters without checking whether the current strlen(buf) + 2 < size. This vulnerability causes programs that use libxml2, such as PHP, to crash.

    • Update to 2.9.4+dfsg1-3.1
    Published Updated
  2. CVE-2017-9047

    High · CVSS 7.5EPSS 3.16%Fix available

    CVE-2017-9047

    A buffer overflow was discovered in libxml2 20904-GITv2.9.4-16-g0741801. The function xmlSnprintfElementContent in valid.c is supposed to recursively dump the element content definition into a char buffer 'buf' of size 'size'. The variable len is assigned strlen(buf). If the content->type is XML_ELEMENT_CONTENT_ELEMENT, then (i) the content->prefix is appended to buf (if it actually fits) whereupon (ii) content->name is written to the buffer. However, the check for whether the content->name actually fits also uses 'len' rather than the updated buffer length strlen(buf). This allows us to write about "size" many bytes beyond the allocated memo

    • Update to 2.9.4+dfsg1-3.1
    Published Updated
  3. CVE-2017-5969

    Medium · CVSS 4.7EPSS 2.63%Fix available

    CVE-2017-5969

    libxml2 2.9.4, when used in recover mode, allows remote attackers to cause a denial of service (NULL pointer dereference) via a crafted XML document. NOTE: The maintainer states "I would disagree of a CVE with the Recover parsing option which should only be used for manual recovery at least for XML parser.

    • Update to 2.9.4+dfsg1-5.1
    Published Updated
  4. CVE-2016-4483

    High · CVSS 7.5EPSS 6%Fix available

    CVE-2016-4483

    The xmlBufAttrSerializeTxtContent function in xmlsave.c in libxml2 allows context-dependent attackers to cause a denial of service (out-of-bounds read and application crash) via a non-UTF-8 attribute value, related to serialization. NOTE: this vulnerability may be a duplicate of CVE-2016-3627.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  5. CVE-2016-9318

    Medium · CVSS 5.5EPSS 2.94%Fix available

    CVE-2016-9318

    libxml2 2.9.4 and earlier, as used in XMLSec 1.2.23 and earlier and other products, does not offer a flag directly indicating that the current document may be read but other files may not be opened, which makes it easier for remote attackers to conduct XML External Entity (XXE) attacks via a crafted document.

    • Update to 2.9.10+dfsg-2
    Published Updated
  6. CVE-2016-4658

    Critical · CVSS 9.8EPSS 8.56%Fix available

    CVE-2016-4658

    xpointer.c in libxml2 before 2.9.5 (as used in Apple iOS before 10, OS X before 10.12, tvOS before 10, and watchOS before 3, and other products) does not forbid namespace nodes in XPointer ranges, which allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free and memory corruption) via a crafted XML document.

    • Update to 2.9.4+dfsg1-2.1
    Published Updated
  7. CVE-2016-4449

    High · CVSS 7.1EPSS 1.66%Fix available

    CVE-2016-4449

    XML external entity (XXE) vulnerability in the xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.4, when not in validating mode, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via unspecified vectors.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  8. CVE-2016-1840

    High · CVSS 7.8EPSS 3.24%Fix available

    CVE-2016-1840

    Heap-based buffer overflow in the xmlFAParsePosCharGroup function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted XML document.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  9. CVE-2016-1839

    Medium · CVSS 5.5EPSS 7.35%Public exploitFix available

    CVE-2016-1839

    The xmlDictAddString function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted XML document.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  10. CVE-2016-1838

    Medium · CVSS 5.5EPSS 7%Public exploitFix available

    CVE-2016-1838

    The xmlPArserPrintFileContextInternal function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted XML document.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  11. CVE-2016-1837

    Medium · CVSS 5.5EPSS 4.45%Fix available

    CVE-2016-1837

    Multiple use-after-free vulnerabilities in the (1) htmlPArsePubidLiteral and (2) htmlParseSystemiteral functions in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allow remote attackers to cause a denial of service via a crafted XML document.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  12. CVE-2016-1834

    High · CVSS 7.8EPSS 4.62%Fix available

    CVE-2016-1834

    Heap-based buffer overflow in the xmlStrncat function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted XML document.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated
  13. CVE-2016-3705

    High · CVSS 7.5EPSS 5.1%Fix available

    CVE-2016-3705

    The (1) xmlParserEntityCheck and (2) xmlParseAttValueComplex functions in parser.c in libxml2 2.9.3 do not properly keep track of the recursion depth, which allows context-dependent attackers to cause a denial of service (stack consumption and application crash) via a crafted XML document containing a large number of nested entity references.

    • Update to 2.9.3+dfsg1-1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →