p PatchFirst

PatchFirst · Latest vulnerabilities

pcre3 vulnerabilities · Page 3

Vulnerabilities published for pcre3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 52

  1. CVE-2006-7230

    Not ratedEPSS 1.67%Fix available

    CVE-2006-7230

    Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate the amount of memory needed for a compiled regular expression pattern when the (1) -x or (2) -i UTF-8 options change within the pattern, which allows context-dependent attackers to cause a denial of service (PCRE or glibc crash) via crafted regular expressions.

    • Update to 7.0-1
    Published Updated
  2. CVE-2006-7228

    Not ratedEPSS 3.66%Fix available

    CVE-2006-7228

    Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 might allow context-dependent attackers to execute arbitrary code via a regular expression that involves large (1) min, (2) max, or (3) duplength values that cause an incorrect length calculation and trigger a buffer overflow, a different vulnerability than CVE-2006-7227. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.

    • Update to 6.2-1
    Published Updated
  3. CVE-2006-7227

    Not ratedEPSS 3.5%Fix available

    CVE-2006-7227

    Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 allows context-dependent attackers to execute arbitrary code via a regular expression containing a large number of named subpatterns (name_count) or long subpattern names (max_name_size), which triggers a buffer overflow. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.

    • Update to 6.2-1
    Published Updated
  4. CVE-2005-4872

    Not ratedEPSS 2.32%Fix available

    CVE-2005-4872

    Perl-Compatible Regular Expression (PCRE) library before 6.2 does not properly count the number of named capturing subpatterns, which allows context-dependent attackers to cause a denial of service (crash) via a regular expression with a large number of named subpatterns, which triggers a buffer overflow. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.

    • Update to 6.2-1
    Published Updated
  5. CVE-2007-4767

    Not ratedEPSS 5.07%Fix available

    CVE-2007-4767

    Perl-Compatible Regular Expression (PCRE) library before 7.3 does not properly compute the length of (1) a \p sequence, (2) a \P sequence, or (3) a \P{x} sequence, which allows context-dependent attackers to cause a denial of service (infinite loop or crash) or execute arbitrary code.

    • Update to 7.3-1
    Published Updated
  6. CVE-2007-1661

    Not ratedEPSS 2.49%Fix available

    CVE-2007-1661

    Perl-Compatible Regular Expression (PCRE) library before 7.3 backtracks too far when matching certain input bytes against some regex patterns in non-UTF-8 mode, which allows context-dependent attackers to obtain sensitive information or cause a denial of service (crash), as demonstrated by the "\X?\d" and "\P{L}?\d" patterns.

    • Update to 7.3-1
    Published Updated
  7. CVE-2007-1660

    Not ratedEPSS 4.08%Fix available

    CVE-2007-1660

    Perl-Compatible Regular Expression (PCRE) library before 7.0 does not properly calculate sizes for unspecified "multiple forms of character class", which triggers a buffer overflow that allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code.

    • Update to 7.3-1
    Published Updated
  8. CVE-2005-2491

    Not ratedEPSS 4.34%Fix available

    CVE-2005-2491

    Integer overflow in pcre_compile.c in Perl Compatible Regular Expressions (PCRE) before 6.2, as used in multiple products such as Python, Ethereal, and PHP, allows attackers to execute arbitrary code via quantifier values in regular expressions, which leads to a heap-based buffer overflow.

    • Update to 6.3-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →