p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 8

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 166

  1. CVE-2015-3228

    Not ratedEPSS 3.88%Fix available

    CVE-2015-3228

    Integer overflow in the gs_heap_alloc_bytes function in base/gsmalloc.c in Ghostscript 9.15 and earlier allows remote attackers to cause a denial of service (crash) via a crafted Postscript (ps) file, as demonstrated by using the ps2pdf command, which triggers an out-of-bounds read or write.

    • Update to 9.15~dfsg-1
    Published Updated
  2. CVE-2012-4405

    Not ratedEPSS 7.49%Fix available

    CVE-2012-4405

    Multiple integer underflows in the icmLut_allocate function in International Color Consortium (ICC) Format library (icclib), as used in Ghostscript 9.06 and Argyll Color Management System, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PostScript or (2) PDF file with embedded images, which triggers a heap-based buffer overflow. NOTE: this issue is also described as an array index error.

    • Update to 9.05~dfsg-6.1
    Published Updated
  3. CVE-2011-4517

    Not ratedEPSS 10.49%Fix available

    CVE-2011-4517

    The jpc_crg_getparms function in libjasper/jpc/jpc_cs.c in JasPer 1.900.1 uses an incorrect data type during a certain size calculation, which allows remote attackers to trigger a heap-based buffer overflow and execute arbitrary code, or cause a denial of service (heap memory corruption), via a crafted component registration (CRG) marker segment in a JPEG2000 file.

    • Update to 8.64~dfsg-2
    Published Updated
  4. CVE-2011-4516

    Not ratedEPSS 10.49%Fix available

    CVE-2011-4516

    Heap-based buffer overflow in the jpc_cox_getcompparms function in libjasper/jpc/jpc_cs.c in JasPer 1.900.1 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted numrlvls value in a coding style default (COD) marker segment in a JPEG2000 file.

    • Update to 8.64~dfsg-2
    Published Updated
  5. CVE-2009-3743

    Not ratedEPSS 6.75%Fix available

    CVE-2009-3743

    Off-by-one error in the Ins_MINDEX function in the TrueType bytecode interpreter in Ghostscript before 8.71 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via a malformed TrueType font in a document that trigger an integer overflow and a heap-based buffer overflow.

    • Update to 8.71~dfsg-1
    Published Updated
  6. CVE-2010-2055

    Not ratedEPSS 0.51%Fix available

    CVE-2010-2055

    Ghostscript 8.71 and earlier reads initialization files from the current working directory, which allows local users to execute arbitrary PostScript commands via a Trojan horse file, related to improper support for the -P- option to the gs program, as demonstrated using gs_init.ps, a different vulnerability than CVE-2010-4820.

    • Update to 8.71~dfsg2-6.1
    Published Updated
  7. CVE-2009-4270

    Not ratedEPSS 6.9%Fix available

    CVE-2009-4270

    Stack-based buffer overflow in the errprintf function in base/gsmisc.c in ghostscript 8.64 through 8.70 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted PDF file, as originally reported for debug logging code in gdevcups.c in the CUPS output driver.

    • Update to 8.70~dfsg-2.1
    Published Updated
  8. CVE-2009-3560

    Not ratedEPSS 24.31%Fix available

    CVE-2009-3560

    The big2_toUtf8 function in lib/xmltok.c in libexpat in Expat 2.0.1, as used in the XML-Twig module for Perl, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with malformed UTF-8 sequences that trigger a buffer over-read, related to the doProlog function in lib/xmlparse.c, a different vulnerability than CVE-2009-2625 and CVE-2009-3720.

    • Update to 8.71~dfsg-2
    Published Updated
  9. CVE-2009-3720

    Not ratedEPSS 27.92%Fix available

    CVE-2009-3720

    The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

    • Update to 8.71~dfsg-2
    Published Updated
  10. CVE-2009-0196

    Not ratedEPSS 7.43%Fix available

    CVE-2009-0196

    Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

    • Update to 8.64~dfsg-1.1
    Published Updated
  11. CVE-2009-0792

    Not ratedEPSS 3.99%Fix available

    CVE-2009-0792

    Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images. NOTE: this issue exists because of an incomplete fix for CVE-2009-0583.

    • Update to 8.64~dfsg-1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →