p PatchFirst

PatchFirst · Latest vulnerabilities

glibc vulnerabilities · Page 7

Vulnerabilities published for glibc in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 169

  1. CVE-2014-6040

    Not ratedEPSS 6.56%Fix available

    CVE-2014-6040

    GNU C Library (aka glibc) before 2.20 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via a multibyte character value of "0xffff" to the iconv function when converting (1) IBM933, (2) IBM935, (3) IBM937, (4) IBM939, or (5) IBM1364 encoded data to UTF-8.

    • Update to 2.19-12
    Published Updated
  2. CVE-2014-5119

    Not ratedEPSS 16.97%Public exploitFix available

    CVE-2014-5119

    Off-by-one error in the __gconv_translit_find function in gconv_trans.c in GNU C Library (aka glibc) allows context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via vectors related to the CHARSET environment variable and gconv transliteration modules.

    • Update to 2.19-10
    Published Updated
  3. CVE-2014-0475

    Not ratedEPSS 2.69%Fix available

    CVE-2014-0475

    Multiple directory traversal vulnerabilities in GNU C Library (aka glibc or libc6) before 2.20 allow context-dependent attackers to bypass ForceCommand restrictions and possibly have other unspecified impact via a .. (dot dot) in a (1) LC_*, (2) LANG, or other locale environment variable.

    • Update to 2.19-6
    Published Updated
  4. CVE-2012-3406

    Not ratedEPSS 3.16%Fix available

    CVE-2012-3406

    The vfprintf function in stdio-common/vfprintf.c in GNU C Library (aka glibc) 2.5, 2.12, and probably other versions does not "properly restrict the use of" the alloca function when allocating the SPECS array, which allows context-dependent attackers to bypass the FORTIFY_SOURCE format-string protection mechanism and cause a denial of service (crash) or possibly execute arbitrary code via a crafted format string using positional parameters and a large number of format specifiers, a different vulnerability than CVE-2012-3404 and CVE-2012-3405.

    • Update to 2.19-14
    Published Updated
  5. CVE-2012-3405

    Not ratedEPSS 2.09%Fix available

    CVE-2012-3405

    The vfprintf function in stdio-common/vfprintf.c in libc in GNU C Library (aka glibc) 2.14 and other versions does not properly calculate a buffer length, which allows context-dependent attackers to bypass the FORTIFY_SOURCE format-string protection mechanism and cause a denial of service (segmentation fault and crash) via a format string with a large number of format specifiers that triggers "desynchronization within the buffer size handling," a different vulnerability than CVE-2012-3404.

    • Update to 2.13-35
    Published Updated
  6. CVE-2012-3404

    Not ratedEPSS 2.23%Fix available

    CVE-2012-3404

    The vfprintf function in stdio-common/vfprintf.c in libc in GNU C Library (aka glibc) 2.12 and other versions does not properly calculate a buffer length, which allows context-dependent attackers to bypass the FORTIFY_SOURCE format-string protection mechanism and cause a denial of service (stack corruption and crash) via a format string that uses positional parameters and many format specifiers.

    • Update to 2.13-35
    Published Updated
  7. CVE-2013-4458

    Not ratedEPSS 4.15%Fix available

    CVE-2013-4458

    Stack-based buffer overflow in the getaddrinfo function in sysdeps/posix/getaddrinfo.c in GNU C Library (aka glibc or libc6) 2.18 and earlier allows remote attackers to cause a denial of service (crash) via a (1) hostname or (2) IP address that triggers a large number of AF_INET6 address results. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-1914.

    • Update to 2.18-1
    Published Updated
  8. CVE-2013-4332

    Not ratedEPSS 2.61%Fix available

    CVE-2013-4332

    Multiple integer overflows in malloc/malloc.c in the GNU C Library (aka glibc or libc6) 2.18 and earlier allow context-dependent attackers to cause a denial of service (heap corruption) via a large value to the (1) pvalloc, (2) valloc, (3) posix_memalign, (4) memalign, or (5) aligned_alloc functions.

    • Update to 2.17-93
    Published Updated
  9. CVE-2012-4424

    Not ratedEPSS 3.38%Fix available

    CVE-2012-4424

    Stack-based buffer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string that triggers a malloc failure and use of the alloca function.

    • Update to 2.17-94
    Published Updated
  10. CVE-2012-4412

    Not ratedEPSS 17.53%Public exploitFix available

    CVE-2012-4412

    Integer overflow in string/strcoll_l.c in the GNU C Library (aka glibc or libc6) 2.17 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string, which triggers a heap-based buffer overflow.

    • Update to 2.17-94
    Published Updated
  11. CVE-2013-4788

    Not ratedEPSS 11.43%Public exploitFix available

    CVE-2013-4788

    The PTR_MANGLE implementation in the GNU C Library (aka glibc or libc6) 2.4, 2.17, and earlier, and Embedded GLIBC (EGLIBC) does not initialize the random value for the pointer guard, which makes it easier for context-dependent attackers to control execution flow by leveraging a buffer-overflow vulnerability in an application and using the known zero value pointer guard to calculate a pointer address.

    • Update to 2.17-94
    Published Updated
  12. CVE-2013-1914

    Not ratedEPSS 4.11%Fix available

    CVE-2013-1914

    Stack-based buffer overflow in the getaddrinfo function in sysdeps/posix/getaddrinfo.c in GNU C Library (aka glibc or libc6) 2.17 and earlier allows remote attackers to cause a denial of service (crash) via a (1) hostname or (2) IP address that triggers a large number of domain conversion results.

    • Update to 2.17-2
    Published Updated
  13. CVE-2012-3480

    Not ratedEPSS 0.99%Public exploitFix available

    CVE-2012-3480

    Multiple integer overflows in the (1) strtod, (2) strtof, (3) strtold, (4) strtod_l, and other unspecified "related functions" in stdlib in GNU C Library (aka glibc or libc6) 2.16 allow local users to cause a denial of service (application crash) and possibly execute arbitrary code via a long string, which triggers a stack-based buffer overflow.

    • Update to 2.13-36
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →