p PatchFirst

PatchFirst · Latest vulnerabilities

imagemagick vulnerabilities · Page 43

Vulnerabilities published for imagemagick in the last 30 days: 82. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 864

  1. CVE-2007-4985

    Not ratedEPSS 1.81%Fix available

    CVE-2007-4985

    ImageMagick before 6.3.5-9 allows context-dependent attackers to cause a denial of service via a crafted image file that triggers (1) an infinite loop in the ReadDCMImage function, related to ReadBlobByte function calls; or (2) an infinite loop in the ReadXCFImage function, related to ReadBlobMSBLong function calls.

    • Update to 7:6.2.4.5.dfsg1-2
    Published Updated
  2. CVE-2007-1797

    Not ratedEPSS 3.56%Fix available

    CVE-2007-1797

    Multiple integer overflows in ImageMagick before 6.3.3-5 allow remote attackers to execute arbitrary code via (1) a crafted DCM image, which results in a heap-based overflow in the ReadDCMImage function, or (2) the (a) colors or (b) comments field in a crafted XWD image, which results in a heap-based overflow in the ReadXWDImage function, different issues than CVE-2007-1667.

    • Update to 7:6.2.4.5.dfsg1-1
    Published Updated
  3. CVE-2007-1667

    Not ratedEPSS 4.76%Fix available

    CVE-2007-1667

    Multiple integer overflows in (1) the XGetPixel function in ImUtil.c in X.Org libx11 before 1.0.3, and (2) XInitImage function in xwd.c for ImageMagick, allow user-assisted remote attackers to cause a denial of service (crash) or obtain sensitive information via crafted images with large or negative values that trigger a buffer overflow.

    • Update to 7:6.2.4.5.dfsg1-1
    Published Updated
  4. CVE-2007-0770

    Not ratedEPSS 5.4%Fix available

    CVE-2007-0770

    Buffer overflow in GraphicsMagick and ImageMagick allows user-assisted remote attackers to cause a denial of service and possibly execute arbitrary code via a PALM image that is not properly handled by the ReadPALMImage function in coders/palm.c. NOTE: this issue is due to an incomplete patch for CVE-2006-5456.

    • Update to 7:6.2.4.5.dfsg1-0.14
    Published Updated
  5. CVE-2006-5456

    Not ratedEPSS 3.79%Fix available

    CVE-2006-5456

    Multiple buffer overflows in GraphicsMagick before 1.1.7 and ImageMagick 6.0.7 allow user-assisted attackers to cause a denial of service and possibly execute arbitrary code via (1) a DCM image that is not properly handled by the ReadDCMImage function in coders/dcm.c, or (2) a PALM image that is not properly handled by the ReadPALMImage function in coders/palm.c.

    • Update to 7:6.2.4.5.dfsg1-0.11
    Published Updated
  6. CVE-2006-4144

    Not ratedEPSS 11.03%Public exploitFix available

    CVE-2006-4144

    Integer overflow in the ReadSGIImage function in sgi.c in ImageMagick before 6.2.9 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via large (1) bytes_per_pixel, (2) columns, and (3) rows values, which trigger a heap-based buffer overflow.

    • Update to 7:6.2.4.5.dfsg1-0.10
    Published Updated
  7. CVE-2006-0082

    Not ratedEPSS 4.34%Fix available

    CVE-2006-0082

    Format string vulnerability in the SetImageInfo function in image.c for ImageMagick 6.2.3 and other versions, and GraphicsMagick, allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via a numeric format string specifier such as %d in the file name, a variant of CVE-2005-0397, and as demonstrated using the convert program.

    • Update to 6:6.2.4.5-0.6
    Published Updated
  8. CVE-2005-0397

    Not ratedEPSS 4.22%Fix available

    CVE-2005-0397

    Format string vulnerability in the SetImageInfo function in image.c for ImageMagick before 6.0.2.5 may allow remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via format string specifiers in a filename argument to convert, which may be called by other web applications.

    • Update to 6:6.0.6.2-2.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →