p PatchFirst

PatchFirst · Latest vulnerabilities

krb5 vulnerabilities · Page 5

Vulnerabilities published for krb5 in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 129

  1. CVE-2009-3295

    Not ratedEPSS 40.34%Fix available

    CVE-2009-3295

    The prep_reprocess_req function in kdc/do_tgs_req.c in the cross-realm referral implementation in the Key Distribution Center (KDC) in MIT Kerberos 5 (aka krb5) 1.7 before 1.7.1 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a ticket request.

    • Update to 1.7+dfsg-4
    Published Updated
  2. CVE-2009-0847

    Not ratedEPSS 2.77%Fix available

    CVE-2009-0847

    The asn1buf_imbed function in the ASN.1 decoder in MIT Kerberos 5 (aka krb5) 1.6.3, when PK-INIT is used, allows remote attackers to cause a denial of service (application crash) via a crafted length value that triggers an erroneous malloc call, related to incorrect calculations with pointer arithmetic.

    • Update to 1.6.dfsg.4~beta1-13
    Published Updated
  3. CVE-2009-0846

    Not ratedEPSS 8.9%Fix available

    CVE-2009-0846

    The asn1_decode_generaltime function in lib/krb5/asn.1/asn1_decode.c in the ASN.1 GeneralizedTime decoder in MIT Kerberos 5 (aka krb5) before 1.6.4 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via vectors involving an invalid DER encoding that triggers a free of an uninitialized pointer.

    • Update to 1.6.dfsg.4~beta1-13
    Published Updated
  4. CVE-2009-0844

    Not ratedEPSS 4.32%Fix available

    CVE-2009-0844

    The get_input_token function in the SPNEGO implementation in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3 allows remote attackers to cause a denial of service (daemon crash) and possibly obtain sensitive information via a crafted length value that triggers a buffer over-read.

    • Update to 1.6.dfsg.4~beta1-13
    Published Updated
  5. CVE-2009-0845

    Not ratedEPSS 5.63%Fix available

    CVE-2009-0845

    The spnego_gss_accept_sec_context function in lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) 1.5 through 1.6.3, when SPNEGO is used, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via invalid ContextFlags data in the reqFlags field in a negTokenInit token.

    • Update to 1.6.dfsg.4~beta1-13
    Published Updated
  6. CVE-2008-0062

    Critical · CVSS 9.8EPSS 10.14%Fix available

    CVE-2008-0062

    KDC in MIT Kerberos 5 (krb5kdc) does not set a global variable for some krb4 message types, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted messages that trigger a NULL pointer dereference or double-free.

    • Update to 1.6.dfsg.3~beta1-4
    Published Updated
  7. CVE-2008-0948

    Not ratedEPSS 7.27%Fix available

    CVE-2008-0948

    Buffer overflow in the RPC library (lib/rpc/rpc_dtablesize.c) used by libgssrpc and kadmind in MIT Kerberos 5 (krb5) 1.2.2, and probably other versions before 1.3, when running on systems whose unistd.h does not define the FD_SETSIZE macro, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code by triggering a large number of open file descriptors.

    • Update to 1.3-1
    Published Updated
  8. CVE-2007-5972

    Not ratedEPSS 2.68%Fix available

    CVE-2007-5972

    Double free vulnerability in the krb5_def_store_mkey function in lib/kdb/kdb_default.c in MIT Kerberos 5 (krb5) 1.5 has unknown impact and remote authenticated attack vectors. NOTE: the free operations occur in code that stores the krb5kdc master key, and so the attacker must have privileges to store this key.

    • Update to 1.6.dfsg.4~beta1-1
    Published Updated
  9. CVE-2007-5894

    Not ratedEPSS 2.69%Fix available

    CVE-2007-5894

    The reply function in ftpd.c in the gssftp ftpd in MIT Kerberos 5 (krb5) does not initialize the length variable when auth_type has a certain value, which has unknown impact and remote authenticated attack vectors. NOTE: the original disclosure misidentifies the conditions under which the uninitialized variable is used. NOTE: the vendor disputes this issue, stating " The 'length' variable is only uninitialized if 'auth_type' is neither the 'KERBEROS_V4' nor 'GSSAPI'; this condition cannot occur in the unmodified source code.

    • Update to 1.6.dfsg.4~beta1-1
    Published Updated
  10. CVE-2007-4743

    Not ratedEPSS 4.61%Fix available

    CVE-2007-4743

    The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

    • Update to 1.6.dfsg.1-7
    Published Updated
  11. CVE-2007-4000

    Not ratedEPSS 6.14%Fix available

    CVE-2007-4000

    The kadm5_modify_policy_internal function in lib/kadm5/srv/svr_policy.c in the Kerberos administration daemon (kadmind) in MIT Kerberos 5 (krb5) 1.5 through 1.6.2 does not properly check return values when the policy does not exist, which might allow remote authenticated users with the "modify policy" privilege to execute arbitrary code via unspecified vectors that trigger a write to an uninitialized pointer.

    • Update to 1.6.dfsg.1-7
    Published Updated
  12. CVE-2007-3999

    Not ratedEPSS 10.91%Fix available

    CVE-2007-3999

    Stack-based buffer overflow in the svcauth_gss_validate function in lib/rpc/svc_auth_gss.c in the RPCSEC_GSS RPC library (librpcsecgss) in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and some third-party applications that use krb5, allows remote attackers to cause a denial of service (daemon crash) and probably execute arbitrary code via a long string in an RPC message.

    • Update to 1.6.dfsg.1-7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →