p PatchFirst

PatchFirst · Latest vulnerabilities

simplesamlphp vulnerabilities · Page 2

Vulnerabilities published for simplesamlphp in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 30

  1. CVE-2017-12871

    Medium · CVSS 5.9EPSS 0.49%Fix available

    CVE-2017-12871

    The aesEncrypt method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.x through 1.14.11 makes it easier for context-dependent attackers to bypass the encryption protection mechanism by leveraging use of the first 16 bytes of the secret key as the initialization vector (IV).

    • Update to 1.14.15-1
    Published Updated
  2. CVE-2017-12870

    Medium · CVSS 5.9EPSS 0.88%Fix available

    CVE-2017-12870

    SimpleSAMLphp 1.14.12 and earlier make it easier for man-in-the-middle attackers to obtain sensitive information by leveraging use of the aesEncrypt and aesDecrypt methods in the SimpleSAML/Utils/Crypto class to protect session identifiers in replies to non-HTTPS service providers.

    • Update to 1.14.15-1
    Published Updated
  3. CVE-2017-12868

    Critical · CVSS 9.8EPSS 2.13%Fix available

    CVE-2017-12868

    The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation.

    • Update to 1.14.15-1
    Published Updated
  4. CVE-2016-9814

    Critical · CVSS 9.1EPSS 2.41%Fix available

    CVE-2016-9814

    The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

    • Update to 1.14.10-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →