p PatchFirst

PatchFirst · Latest vulnerabilities

@babel/plugin-transform-modules-systemjs vulnerabilities

Vulnerabilities published for @babel/plugin-transform-modules-systemjs in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-44728

    High · CVSS 8.2EPSS 0.12%Fix available

    Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs

    Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.

    • Update to 7.29.4
    • Update to 8.0.0-alpha.13
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →