p PatchFirst

PatchFirst · Latest vulnerabilities

@tygo-van-den-hurk/slyde vulnerabilities

Vulnerabilities published for @tygo-van-den-hurk/slyde in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-26974

    High · CVSS 7.6EPSS 0.61%Fix available

    Sylde has Improper Control of Generation of Code

    Slyde is a program that creates animated presentations from XML. In versions 0.0.4 and below, Node.js automatically imports **/*.plugin.{js,mjs} files including those from node_modules, so any malicious package with a .plugin.js file can execute arbitrary code when installed or required. All projects using this loading behavior are affected, especially those installing untrusted packages. This issue has been fixed in version 0.0.5. To workaround this issue, users can audit and restrict which packages are installed in node_modules.

    • Update to 0.0.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →