p PatchFirst

PatchFirst · Latest vulnerabilities

google-closure-library vulnerabilities

Vulnerabilities published for google-closure-library in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. GHSA-r9q4-w3fm-wrm2

    Not ratedFix available

    Cross-Site Scripting in google-closure-library

    Versions of `google-closure-library` prior to 20190301.0.0 are vulnerable to Cross-Site Scripting. The `safedomtreeprocessor.processToString()` function improperly processed empty elements, which could allow attackers to execute arbitrary JavaScript through Mutation Cross-Site Scripting. ## Recommendation Upgrade to version 20190301.0.0 or later.

    • Update to 20190301.0.0
    Published Updated
  2. CVE-2020-8910

    Medium · CVSS 6.5EPSS 0.54%Fix available

    Auth Bypass in Google's Closure-Library

    A URL parsing issue in goog.uri of the Google Closure Library versions up to and including v20200224 allows an attacker to send malicious URLs to be parsed by the library and return the wrong authority. Mitigation: update your library to version v20200315.

    • Update to 20200315.0.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →