p PatchFirst

PatchFirst · Latest vulnerabilities

openclaw 2026.5.3: known vulnerabilities · Page 3

Known vulnerabilities affecting openclaw 2026.5.3: 45. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 45

  1. CVE-2026-53806

    High · CVSS 7.7EPSS 0.42%Fix available

    OpenClaw < 2026.5.12 - Shell Option Parsing Bypass in Exec Revalidation

    OpenClaw before 2026.5.12 contains a shell option parsing vulnerability that allows combined POSIX shell flags to bypass exec revalidation checks. Attackers can exploit this by using combined shell options to execute inline shell content without intended allowlist validation, potentially enabling unauthorized command execution when the affected feature is enabled.

    • Update to 2026.5.12
    Published Updated
  2. CVE-2026-35674

    High · CVSS 8.7EPSS 0.25%Fix available

    OpenClaw < 2026.5.18 - Scope Bypass via Inherited chat.send Route

    OpenClaw before 2026.5.18 contains a scope bypass vulnerability in the Gateway chat.send route that allows scoped clients to execute privileged commands. Attackers with operator.write scope can deliver commands through inherited external routes to bypass operator.approvals and operator.admin scope requirements, enabling unauthorized plugin, config, MCP, allowlist, and ACP mutations.

    • Update to 2026.5.18
    Published Updated
  3. CVE-2026-35630

    High · CVSS 7.5EPSS 0.21%Fix available

    OpenClaw < 2026.5.18 - QQBot Missing Approver Identity Enforcement in Native Approval Buttons

    OpenClaw before 2026.5.18 contains an authorization bypass vulnerability in QQBot native approval buttons that fails to enforce configured approver identity. Non-approver users can click approval buttons to resolve pending exec or plugin approval requests without proper authorization.

    • Update to 2026.5.18
    Published Updated
  4. CVE-2026-32906

    Low · CVSS 2.3EPSS 0.17%Fix available

    OpenClaw < 2026.5.12 - Privilege Escalation in Slack Plugin Approvals via Exec Approver Gate

    OpenClaw before 2026.5.12 contains a privilege escalation vulnerability in Slack plugin approvals that allows exec-authorized users to resolve plugin approvals through the exec approver gate. Attackers with limited exec approval permissions can bypass intended approval splits to approve plugin actions outside operator configuration.

    • Update to 2026.5.12
    Published Updated
  5. CVE-2026-32905

    High · CVSS 8.7EPSS 0.24%Fix available

    OpenClaw < 2026.5.4 - Unauthorized Device-Pairing Bootstrap Code Issuance via Chat Command

    OpenClaw before 2026.5.4 contains an authorization bypass vulnerability in the bundled device-pair plugin that allows non-owner authorized chat senders to issue device-pairing bootstrap codes without proper scope validation. Attackers with chat command access can create setup codes to enroll devices with operator/node capabilities, granting persistent credentials until manual removal.

    • Update to 2026.5.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →