p PatchFirst

PatchFirst · Latest vulnerabilities

contao/core-bundle vulnerabilities · Page 2

Vulnerabilities published for contao/core-bundle in the last 30 days: 6. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 40

  1. CVE-2024-28235

    High · CVSS 8.4EPSS 0.71%Fix available

    Contao possible cookie sharing with external domains while checking protected pages for broken links

    Contao is an open source content management system. Starting in version 4.9.0 and prior to versions 4.13.40 and 5.3.4, when checking for broken links on protected pages, Contao sends the cookie header to external urls as well, the passed options for the http client are used for all requests. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, disable crawling protected pages.

    • Update to 4.13.40
    • Update to 5.3.4
    Published Updated
  2. CVE-2024-28191

    Low · CVSS 3.1EPSS 0.5%Fix available

    Contao may have unencoded insert tags in the frontend

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.

    • Update to 4.13.40
    • Update to 5.3.4
    Published Updated
  3. CVE-2024-28190

    Medium · CVSS 5.4EPSS 0.5%Fix available

    Contao core bundle vulnerable to cross site scripting in the file manager

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, remove upload fields from frontend forms and disable uploads for untrusted back end users.

    • Update to 4.13.40
    • Update to 5.3.4
    Published Updated
  4. CVE-2023-36806

    Medium · CVSS 6.5EPSS 0.64%Fix available

    Contao cross site scripting vulnerability via input unit widget

    Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

    • Update to 4.13.28
    • Update to 4.9.42
    • Update to 5.1.10
    Published Updated
  5. CVE-2022-24899

    High · CVSS 7.2EPSS 4.48%Public exploitFix available

    Cross site scripting via canonical tag

    Contao is a powerful open source CMS that allows you to create professional websites and scalable web applications. In versions of Contao prior to 4.13.3 it is possible to inject code into the canonical tag. As a workaround users may disable canonical tags in the root page settings.

    • Update to 4.13.3
    Published Updated
  6. CVE-2021-37627

    High · CVSS 8EPSS 1.02%Fix available

    Privilege escalation via form generator

    Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

    • Update to 4.11.7
    • Update to 4.4.56
    • Update to 4.9.18
    Published Updated
  7. CVE-2021-37626

    High · CVSS 7.2EPSS 1.25%Fix available

    PHP file inclusion via insert tags

    Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.

    • Update to 4.11.7
    • Update to 4.4.56
    • Update to 4.9.18
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →