p PatchFirst

PatchFirst · Latest vulnerabilities

drupal/drupal vulnerabilities · Page 3

Vulnerabilities published for drupal/drupal in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 81

  1. CVE-2017-6924

    High · CVSS 7.4EPSS 2.1%Fix available

    REST API can bypass comment approval - Access Bypass - Moderately Critical

    In Drupal 8 prior to 8.3.7; When using the REST API, users without the correct permission can post comments via REST that are approved even if the user does not have permission to post approved comments. This issue only affects sites that have the RESTful Web Services (rest) module enabled, the comment entity REST resource enabled, and where an attacker can access a user account on the site with permissions to post comments, or where anonymous users can post comments.

    • Update to 8.3.7
    Published Updated
  2. CVE-2017-6925

    Critical · CVSS 9.8EPSS 3.02%Fix available

    CVE-2017-6925

    In versions of Drupal 8 core prior to 8.3.7; There is a vulnerability in the entity access system that could allow unwanted access to view, create, update, or delete entities. This only affects entities that do not use or do not have UUIDs, and entities that have different access restrictions on different revisions of the same entity.

    • Update to 8.3.7
    Published Updated
  3. CVE-2018-7602

    High · CVSS 8.1EPSS 99.17%In KEVPublic exploitFix available

    Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004

    A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.

    • Update to 7.59
    • Update to 8.4.8
    • Update to 8.5.3
    Published Updated
  4. CVE-2018-9861

    Medium · CVSS 6.1EPSS 1.72%Fix available

    CVE-2018-9861

    Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.

    • Update to 8.4.7
    • Update to 8.5.2
    Published Updated
  5. CVE-2018-7600

    Critical · CVSS 9.8EPSS 99.99%In KEVPublic exploitFix available

    CVE-2018-7600

    Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

    • Update to 7.58
    • Update to 8.3.9
    • Update to 8.4.6
    • Update to 8.5.1
    Published Updated
  6. CVE-2017-6932

    Medium · CVSS 4.7EPSS 1.17%Fix available

    CVE-2017-6932

    Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.

    • Update to 7.57
    Published Updated
  7. CVE-2017-6931

    Medium · CVSS 6.5EPSS 1.07%Fix available

    CVE-2017-6931

    In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.

    • Update to 8.4.5
    Published Updated
  8. CVE-2017-6930

    High · CVSS 8.1EPSS 1.29%Fix available

    CVE-2017-6930

    In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().

    • Update to 8.4.5
    Published Updated
  9. CVE-2017-6929

    Medium · CVSS 6.1EPSS 1.22%Fix available

    CVE-2017-6929

    A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.

    • Update to 7.57
    • Update to 8.4.0
    Published Updated
  10. CVE-2017-6928

    Medium · CVSS 5.3EPSS 1.02%Fix available

    CVE-2017-6928

    Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.

    • Update to 7.57
    Published Updated
  11. CVE-2017-6927

    Medium · CVSS 6.1EPSS 1.61%Fix available

    CVE-2017-6927

    Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

    • Update to 7.57
    • Update to 8.4.5
    Published Updated
  12. CVE-2017-6926

    High · CVSS 8.1EPSS 1.21%Fix available

    CVE-2017-6926

    In Drupal versions 8.4.x versions before 8.4.5 users with permission to post comments are able to view content and comments they do not have access to, and are also able to add comments to this content. This vulnerability is mitigated by the fact that the comment system must be enabled and the attacker must have permission to post comments.

    • Update to 7.57
    • Update to 8.4.5
    Published Updated
  13. CVE-2017-6381

    High · CVSS 8.1EPSS 3.9%Fix available

    CVE-2017-6381

    A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments

    • Update to 8.2.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →