p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki/core vulnerabilities · Page 2

Vulnerabilities published for mediawiki/core in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2019-12468

    Critical · CVSS 9.8EPSS 3.33%Fix available

    CVE-2019-12468

    An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.

    • Update to 1.27.6
    • Update to 1.30.2
    • Update to 1.31.2
    • Update to 1.32.2
    Published Updated
  2. CVE-2019-12467

    Medium · CVSS 5.3EPSS 1.26%Fix available

    CVE-2019-12467

    MediaWiki through 1.32.1 has Incorrect Access Control (issue 1 of 3). A spammer can use Special:ChangeEmail to send out spam with no rate limiting or ability to block them. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

    • Update to 1.27.6
    • Update to 1.30.2
    • Update to 1.31.2
    • Update to 1.32.2
    Published Updated
  3. CVE-2018-0503

    Medium · CVSS 4.3EPSS 1.56%Fix available

    $wgRateLimits entry for 'user' overrides 'newbie'

    Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user' overrides that for 'newbie'.

    • Update to 1.27.5
    • Update to 1.29.3
    • Update to 1.30.1
    • Update to 1.31.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →