p PatchFirst

PatchFirst · Latest vulnerabilities

infrahub-server vulnerabilities

Vulnerabilities published for infrahub-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-59036

    Medium · CVSS 5.5EPSS 0.19%Fix available

    Infrahub allows authentication with deleted and expired API tokens

    Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.

    • Update to 1.3.9
    • Update to 1.4.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →