p PatchFirst

PatchFirst · Latest vulnerabilities

moin vulnerabilities · Page 2

Vulnerabilities published for moin in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 41

  1. CVE-2010-0667

    High · CVSS 8.7EPSS 1.87%Fix available

    CVE-2010-0667

    MoinMoin 1.9 before 1.9.1 does not perform the expected clearing of the sys.argv array in situations where the GATEWAY_INTERFACE environment variable is set, which allows remote attackers to obtain sensitive information via unspecified vectors.

    • Update to 1.9.1
    Published Updated
  2. CVE-2009-1482

    Medium · CVSS 6.1EPSS 2.5%Fix available

    CVE-2009-1482

    Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin 1.8.2 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) an AttachFile sub-action in the error_msg function or (2) multiple vectors related to package file errors in the upload_form function, different vectors than CVE-2009-0260.

    • Update to 1.8.3
    Published Updated
  3. CVE-2008-6549

    High · CVSS 8.7EPSS 1.48%Fix available

    CVE-2008-6549

    The password_checker function in config/multiconfig.py in MoinMoin 1.6.1 uses the cracklib and python-crack features even though they are not thread-safe, which allows remote attackers to cause a denial of service (segmentation fault and crash) via unknown vectors.

    • Update to 1.6.1
    Published Updated
  4. CVE-2009-0260

    Not ratedEPSS 5.48%Public exploitFix available

    CVE-2009-0260

    Multiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin before 1.8.1 allow remote attackers to inject arbitrary web script or HTML via an AttachFile action to the WikiSandBox component with (1) the rename parameter or (2) the drawing parameter (aka the basename variable).

    • Update to 1.8.1
    Published Updated
  5. CVE-2008-1098

    Not ratedEPSS 1.82%No fix published

    CVE-2008-1098

    Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.5.8 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) certain input processed by formatter/text_gedit.py (aka the gui editor formatter); (2) a page name, which triggers an injection in PageEditor.py when the page is successfully deleted by a victim in a DeletePage action; or (3) the destination page name for a RenamePage action, which triggers an injection in PageEditor.py when a victim's rename attempt fails because of a duplicate name. NOTE: the AttachFile XSS issue is already covered by CVE-2008-0781, and the login XSS issue is already covere

    Published Updated
  6. CVE-2008-0782

    Not ratedEPSS 14.9%Public exploitNo fix published

    CVE-2008-0782

    Directory traversal vulnerability in MoinMoin 1.5.8 and earlier allows remote attackers to overwrite arbitrary files via a .. (dot dot) in the MOIN_ID user ID in a cookie for a userform action. NOTE: this issue can be leveraged for PHP code execution via the quicklinks parameter.

    Published Updated
  7. CVE-2007-0902

    Not ratedEPSS 1.36%Fix available

    CVE-2007-0902

    Unspecified vulnerability in the "Show debugging information" feature in MoinMoin 1.5.7 allows remote attackers to obtain sensitive information. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.

    • Update to 1.5.8
    Published Updated
  8. CVE-2007-0901

    Not ratedEPSS 1.78%Fix available

    CVE-2007-0901

    Multiple cross-site scripting (XSS) vulnerabilities in Info pages in MoinMoin 1.5.7 allow remote attackers to inject arbitrary web script or HTML via the (1) hitcounts and (2) general parameters, different vectors than CVE-2007-0857. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.

    • Update to 1.5.8
    Published Updated
  9. CVE-2007-0857

    Not ratedEPSS 2.42%Fix available

    CVE-2007-0857

    Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin before 1.5.7 allow remote attackers to inject arbitrary web script or HTML via (1) the page info, or the page name in a (2) AttachFile, (3) RenamePage, or (4) LocalSiteMap action.

    • Update to 1.5.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →