p PatchFirst

PatchFirst · Latest vulnerabilities

pillow vulnerabilities · Page 6

Vulnerabilities published for pillow in the last 30 days: 41. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 119

  1. CVE-2019-19911

    High · CVSS 8.7EPSS 2.24%Fix available

    CVE-2019-19911

    There is a DoS vulnerability in Pillow before 6.2.2 caused by FpxImagePlugin.py calling the range function on an unvalidated 32-bit integer if the number of bands is large. On Windows running 32-bit Python, this results in an OverflowError or MemoryError due to the 2 GB limit. However, on Linux running 64-bit Python this results in the process being terminated by the OOM killer.

    • Update to 6.2.2
    Published Updated
  2. CVE-2014-1933

    Medium · CVSS 5.1EPSS 0.45%Fix available

    CVE-2014-1933

    The (1) JpegImagePlugin.py and (2) EpsImagePlugin.py scripts in Python Image Library (PIL) 1.1.7 and earlier and Pillow before 2.3.1 uses the names of temporary files on the command line, which makes it easier for local users to conduct symlink attacks by listing the processes.

    • Update to 2.3.1
    Published Updated
  3. CVE-2014-1932

    High · CVSS 8.5EPSS 0.5%Fix available

    CVE-2014-1932

    The (1) load_djpeg function in JpegImagePlugin.py, (2) Ghostscript function in EpsImagePlugin.py, (3) load function in IptcImagePlugin.py, and (4) _copy function in Image.py in Python Image Library (PIL) 1.1.7 and earlier and Pillow before 2.3.1 do not properly create temporary files, which allow local users to overwrite arbitrary files and obtain sensitive information via a symlink attack on the temporary file.

    • Update to 2.3.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →