p PatchFirst

PatchFirst · Latest vulnerabilities

PHP stack vulnerabilities · Page 185

Vulnerabilities published for PHP in the last 30 days: 222. Listed in the KEV catalogue: 2.

Filter vulnerabilities
PHP

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 7239

  1. CVE-2023-37611

    Medium · CVSS 5.4EPSS 0.71%Fix available

    CVE-2023-37611

    Cross Site Scripting (XSS) vulnerability in Neos CMS 8.3.3 allows a remote authenticated attacker to execute arbitrary code via a crafted SVG file to the neos/management/media component.

    • Update to 7.3.19
    • Update to 8.0.16
    • Update to 8.1.11
    • Update to 8.2.11
    • Update to 8.3.9
    Published Updated
  2. CVE-2023-41892

    Critical · CVSS 10EPSS 94.22%Public exploitFix available

    Craft CMS Remote Code Execution vulnerability

    Craft CMS is a platform for creating digital experiences. This is a high-impact, low-complexity attack vector. Users running Craft installations before 4.4.15 are encouraged to update to at least that version to mitigate the issue. This issue has been fixed in Craft CMS 4.4.15.

    • Update to 4.4.15
    Published Updated
  3. DRUPAL-CONTRIB-2023-045

    Not ratedFix available

    DRUPAL-CONTRIB-2023-045

    This module enables users to log in by email address with minimal configurations. Drupal core contains protection against brute force attacks via a flood control mechanism. This module's functionality did not replicate the flood control, enabling brute force attacks.

    • Update to 2.8.0
    Published Updated
  4. CVE-2022-24093

    Critical · CVSS 9.1EPSS 1.51%Fix available

    Adobe Commerce post-auth improper input validation leads to remote code execution

    Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.

    • Update to 2.3.7-p3
    • Update to 2.4.3-p2
    Published Updated
  5. CVE-2023-41879

    High · CVSS 7.5EPSS 1.25%Fix available

    Magento LTS's guest order "protect code" can be brute-forced too easily

    Magento LTS is the official OpenMage LTS codebase. Guest orders may be viewed without authentication using a "guest-view" cookie which contains the order's "protect_code". This code is 6 hexadecimal characters which is arguably not enough to prevent a brute-force attack. Exposing each order would require a separate brute force attack. This issue has been patched in versions 19.5.1 and 20.1.1.

    • Update to 19.5.1
    • Update to 20.1.1
    Published Updated
  6. CVE-2023-41336

    Medium · CVSS 6.5EPSS 0.64%Fix available

    Prevent injection of invalid entity ids for "autocomplete" fields in symfony ux-autocomplete

    ux-autocomplete is a JavaScript Autocomplete functionality for Symfony. Under certain circumstances, an attacker could successfully submit an entity id for an `EntityType` that is *not* part of the valid choices. The problem has been fixed in `symfony/ux-autocomplete` version 2.11.2.

    • Update to 2.11.2
    Published Updated
  7. CVE-2023-41330

    Critical · CVSS 9.8EPSS 2.29%Fix available

    Unsafe deserialization in knplabs/knp-snappy

    knplabs/knp-snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. ## Issue On March 17th the vulnerability CVE-2023-28115 was disclosed, allowing an attacker to gain remote code execution through PHAR deserialization. Version 1.4.2 added a check `if (\strpos($filename, 'phar://') === 0)` in the `prepareOutput` function to resolve this CVE, however if the user is able to control the second parameter of the `generateFromHtml()` function of Snappy, it will then be passed as the `$filename` parameter in the `prepareOutput()` function. In the original vulnerability, a file name with a `phar://` wrapper

    • Update to 1.4.3
    Published Updated
  8. DRUPAL-CONTRIB-2023-044

    Not ratedFix available

    DRUPAL-CONTRIB-2023-044

    The Webprofiler module provides a way of displaying the Symfony profile debugging tool at the bottom of each page. The abbr\_class Twig filter can be used to bypass the Twig auto-escape feature. This vulnerability is mitigated by the fact that it is only exposed when the filter is specifically used in a theme to render content that contains an attack vector.

    • Update to 10.1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →