p PatchFirst

PatchFirst · Latest vulnerabilities

dbus vulnerabilities

Vulnerabilities published for dbus in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 10

  1. CVE-2015-0245

    Not ratedEPSS 0.27%Fix available

    CVE-2015-0245

    D-Bus 1.4.x through 1.6.x before 1.6.30, 1.8.x before 1.8.16, and 1.9.x before 1.9.10 does not validate the source of ActivationFailure signals, which allows local users to cause a denial of service (activation failure error returned) by leveraging a race condition involving sending an ActivationFailure signal before systemd responds.

    • Update to 1.6.18-0ubuntu4.4
    Published Updated
  2. CVE-2014-7824

    Not ratedEPSS 0.59%Fix available

    CVE-2014-7824

    D-Bus 1.3.0 through 1.6.x before 1.6.26, 1.8.x before 1.8.10, and 1.9.x before 1.9.2 allows local users to cause a denial of service (prevention of new connections and connection drop) by queuing the maximum number of file descriptors. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3636.1.

    • Update to 1.6.18-0ubuntu4.3
    Published Updated
  3. CVE-2014-3636

    Not ratedEPSS 0.51%Fix available

    CVE-2014-3636

    D-Bus 1.3.0 through 1.6.x before 1.6.24 and 1.8.x before 1.8.8 allows local users to (1) cause a denial of service (prevention of new connections and connection drop) by queuing the maximum number of file descriptors or (2) cause a denial of service (disconnect) via multiple messages that combine to have more than the allowed number of file descriptors for a single sendmsg call.

    • Update to 1.6.18-0ubuntu4.2
    Published Updated
  4. CVE-2014-3639

    Not ratedEPSS 0.4%Fix available

    CVE-2014-3639

    The dbus-daemon in D-Bus before 1.6.24 and 1.8.x before 1.8.8 does not properly close old connections, which allows local users to cause a denial of service (incomplete connection consumption and prevention of new connections) via a large number of incomplete connections.

    • Update to 1.6.18-0ubuntu4.2
    Published Updated
  5. CVE-2014-3635

    Not ratedEPSS 0.49%Fix available

    CVE-2014-3635

    Off-by-one error in D-Bus 1.3.0 through 1.6.x before 1.6.24 and 1.8.x before 1.8.8, when running on a 64-bit system and the max_message_unix_fds limit is set to an odd number, allows local users to cause a denial of service (dbus-daemon crash) or possibly execute arbitrary code by sending one more file descriptor than the limit, which triggers a heap-based buffer overflow or an assertion failure.

    • Update to 1.6.18-0ubuntu4.2
    Published Updated
  6. CVE-2014-3532

    Not ratedEPSS 0.45%Fix available

    CVE-2014-3532

    dbus 1.3.0 before 1.6.22 and 1.8.x before 1.8.6, when running on Linux 2.6.37-rc4 or later, allows local users to cause a denial of service (system-bus disconnect of other services or applications) by sending a message containing a file descriptor, then exceeding the maximum recursion depth before the initial message is forwarded.

    • Update to 1.6.18-0ubuntu4.1
    Published Updated
  7. CVE-2014-3477

    Medium · CVSS 4EPSS 0.44%Fix available

    CVE-2014-3477

    The dbus-daemon in D-Bus 1.2.x through 1.4.x, 1.6.x before 1.6.20, and 1.8.x before 1.8.4, sends an AccessDenied error to the service instead of a client when the client is prohibited from accessing the service, which allows local users to cause a denial of service (initialization failure and exit) or possibly conduct a side-channel attack via a D-Bus message to an inactive service.

    • Update to 1.6.18-0ubuntu4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →