p PatchFirst

PatchFirst · Latest vulnerabilities

eglibc vulnerabilities · Page 2

Vulnerabilities published for eglibc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 34

  1. CVE-2015-1781

    Not ratedEPSS 5.01%Fix available

    CVE-2015-1781

    Buffer overflow in the gethostbyname_r and other unspecified NSS functions in the GNU C Library (aka glibc or libc6) before 2.22 allows context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via a crafted DNS response, which triggers a call with a misaligned buffer.

    • Update to 2.19-0ubuntu6.8
    Published Updated
  2. CVE-2015-1473

    Not ratedEPSS 2.13%Fix available

    CVE-2015-1473

    The ADDW macro in stdio-common/vfscanf.c in the GNU C Library (aka glibc or libc6) before 2.21 does not properly consider data-type size during a risk-management decision for use of the alloca function, which might allow context-dependent attackers to cause a denial of service (segmentation violation) or overwrite memory locations beyond the stack boundary via a long line containing wide characters that are improperly handled in a wscanf call.

    • Update to 2.19-0ubuntu6.6
    Published Updated
  3. CVE-2015-1472

    Not ratedEPSS 4.69%Fix available

    CVE-2015-1472

    The ADDW macro in stdio-common/vfscanf.c in the GNU C Library (aka glibc or libc6) before 2.21 does not properly consider data-type size during memory allocation, which allows context-dependent attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a long line containing wide characters that are improperly handled in a wscanf call.

    • Update to 2.19-0ubuntu6.6
    Published Updated
  4. CVE-2014-8121

    Not ratedEPSS 5.61%Fix available

    CVE-2014-8121

    DB_LOOKUP in nss_files/files-XXX.c in the Name Service Switch (NSS) in GNU C Library (aka glibc or libc6) 2.21 and earlier does not properly check if a file is open, which allows remote attackers to cause a denial of service (infinite loop) by performing a look-up on a database while iterating over it, which triggers the file pointer to be reset.

    • Update to 2.19-0ubuntu6.8
    Published Updated
  5. CVE-2014-9402

    Not ratedEPSS 7.83%Fix available

    CVE-2014-9402

    The nss_dns implementation of getnetbyname in GNU C Library (aka glibc) before 2.21, when the DNS backend in the Name Service Switch configuration is enabled, allows remote attackers to cause a denial of service (infinite loop) by sending a positive answer while a network name is being process.

    • Update to 2.19-0ubuntu6.6
    Published Updated
  6. CVE-2013-7423

    Not ratedEPSS 5.81%Fix available

    CVE-2013-7423

    The send_dg function in resolv/res_send.c in GNU C Library (aka glibc or libc6) before 2.20 does not properly reuse file descriptors, which allows remote attackers to send DNS queries to unintended locations via a large number of requests that trigger a call to the getaddrinfo function.

    • Update to 2.19-0ubuntu6.6
    Published Updated
  7. CVE-2014-6040

    Not ratedEPSS 6.56%Fix available

    CVE-2014-6040

    GNU C Library (aka glibc) before 2.20 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via a multibyte character value of "0xffff" to the iconv function when converting (1) IBM933, (2) IBM935, (3) IBM937, (4) IBM939, or (5) IBM1364 encoded data to UTF-8.

    • Update to 2.19-0ubuntu6.4
    Published Updated
  8. CVE-2014-5119

    Not ratedEPSS 16.97%Public exploitFix available

    CVE-2014-5119

    Off-by-one error in the __gconv_translit_find function in gconv_trans.c in GNU C Library (aka glibc) allows context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via vectors related to the CHARSET environment variable and gconv transliteration modules.

    • Update to 2.19-0ubuntu6.3
    Published Updated
  9. CVE-2014-0475

    Not ratedEPSS 2.69%Fix available

    CVE-2014-0475

    Multiple directory traversal vulnerabilities in GNU C Library (aka glibc or libc6) before 2.20 allow context-dependent attackers to bypass ForceCommand restrictions and possibly have other unspecified impact via a .. (dot dot) in a (1) LC_*, (2) LANG, or other locale environment variable.

    • Update to 2.19-0ubuntu6.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →