p PatchFirst

PatchFirst · Latest vulnerabilities

postgresql-9.3 vulnerabilities · Page 2

Vulnerabilities published for postgresql-9.3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 31

  1. CVE-2015-5288

    Not ratedEPSS 4.53%Fix available

    CVE-2015-5288

    The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x before 9.2.14, 9.3.x before 9.3.10, and 9.4.x before 9.4.5 allows attackers to cause a denial of service (server crash) or read arbitrary server memory via a "too-short" salt.

    • Update to 9.3.10-0ubuntu0.14.04
    Published Updated
  2. CVE-2015-3165

    Not ratedEPSS 8.44%Fix available

    CVE-2015-3165

    Double free vulnerability in PostgreSQL before 9.0.20, 9.1.x before 9.1.16, 9.2.x before 9.2.11, 9.3.x before 9.3.7, and 9.4.x before 9.4.2 allows remote attackers to cause a denial of service (crash) by closing an SSL session at a time when the authentication timeout will expire during the session shutdown sequence.

    • Update to 9.3.7-0ubuntu0.14.04
    Published Updated
  3. CVE-2014-0067

    Not ratedEPSS 0.48%Fix available

    CVE-2014-0067

    The "make check" command for the test suites in PostgreSQL 9.3.3 and earlier does not properly invoke initdb to specify the authentication requirements for a database cluster to be used for the tests, which allows local users to gain privileges by leveraging access to this cluster.

    • Update to 9.3.5-0ubuntu0.14.04.1
    Published Updated
  4. CVE-2014-0066

    Not ratedEPSS 4.68%Fix available

    CVE-2014-0066

    The chkpass extension in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 does not properly check the return value of the crypt library function, which allows remote authenticated users to cause a denial of service (NULL pointer dereference and crash) via unspecified vectors.

    • Update to 9.3.3-1
    Published Updated
  5. CVE-2014-0064

    Not ratedEPSS 5.35%Fix available

    CVE-2014-0064

    Multiple integer overflows in the path_in and other unspecified functions in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to have unspecified impact and attack vectors, which trigger a buffer overflow. NOTE: this identifier has been SPLIT due to different affected versions; use CVE-2014-2669 for the hstore vector.

    • Update to 9.3.3-1
    Published Updated
  6. CVE-2014-0063

    Not ratedEPSS 6.67%Fix available

    CVE-2014-0063

    Multiple stack-based buffer overflows in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to cause a denial of service (crash) or possibly execute arbitrary code via vectors related to an incorrect MAXDATELEN constant and datetime values involving (1) intervals, (2) timestamps, or (3) timezones, a different vulnerability than CVE-2014-0065.

    • Update to 9.3.3-1
    Published Updated
  7. CVE-2014-0062

    Not ratedEPSS 3.04%Fix available

    CVE-2014-0062

    Race condition in the (1) CREATE INDEX and (2) unspecified ALTER TABLE commands in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allows remote authenticated users to create an unauthorized index or read portions of unauthorized tables by creating or deleting a table with the same name during the timing window.

    • Update to 9.3.3-1
    Published Updated
  8. CVE-2014-0061

    Not ratedEPSS 4.93%Fix available

    CVE-2014-0061

    The validator functions for the procedural languages (PLs) in PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 allow remote authenticated users to gain privileges via a function that is (1) defined in another language or (2) not allowed to be directly called by the user due to permissions.

    • Update to 9.3.3-1
    Published Updated
  9. CVE-2014-0060

    Not ratedEPSS 4.12%Fix available

    CVE-2014-0060

    PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 does not properly enforce the ADMIN OPTION restriction, which allows remote authenticated members of a role to add or remove arbitrary users to that role by calling the SET ROLE command before the associated GRANT command.

    • Update to 9.3.3-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →