p PatchFirst

PatchFirst · Latest vulnerabilities

qemu vulnerabilities · Page 8

Vulnerabilities published for qemu in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 195

  1. CVE-2016-1568

    High · CVSS 8.8EPSS 0.53%Fix available

    CVE-2016-1568

    Use-after-free vulnerability in hw/ide/ahci.c in QEMU, when built with IDE AHCI Emulation support, allows guest OS users to cause a denial of service (instance crash) or possibly execute arbitrary code via an invalid AHCI Native Command Queuing (NCQ) AIO command.

    • Update to 2.0.0+dfsg-2ubuntu1.22
    Published Updated
  2. CVE-2016-1714

    High · CVSS 8.1EPSS 6.08%Fix available

    CVE-2016-1714

    The (1) fw_cfg_write and (2) fw_cfg_read functions in hw/nvram/fw_cfg.c in QEMU before 2.4, when built with the Firmware Configuration device emulation support, allow guest OS users with the CAP_SYS_RAWIO privilege to cause a denial of service (out-of-bounds read or write access and process crash) or possibly execute arbitrary code via an invalid current entry value in a firmware configuration.

    • Update to 2.0.0+dfsg-2ubuntu1.22
    Published Updated
  3. CVE-2015-7295

    Not ratedEPSS 4.8%Fix available

    CVE-2015-7295

    hw/virtio/virtio.c in the Virtual Network Device (virtio-net) support in QEMU, when big or mergeable receive buffers are not supported, allows remote attackers to cause a denial of service (guest network consumption) via a flood of jumbo frames on the (1) tuntap or (2) macvtap interface.

    • Update to 2.0.0+dfsg-2ubuntu1.21
    Published Updated
  4. CVE-2015-6855

    High · CVSS 7.5EPSS 3.5%Fix available

    CVE-2015-6855

    hw/ide/core.c in QEMU does not properly restrict the commands accepted by an ATAPI device, which allows guest users to cause a denial of service or possibly have unspecified other impact via certain IDE commands, as demonstrated by a WIN_READ_NATIVE_MAX command to an empty drive, which triggers a divide-by-zero error and instance crash.

    • Update to 2.0.0+dfsg-2ubuntu1.19
    Published Updated
  5. CVE-2015-3214

    Not ratedEPSS 1.59%Public exploitFix available

    CVE-2015-3214

    The pit_ioport_read in i8254.c in the Linux kernel before 2.6.33 and QEMU before 2.3.1 does not distinguish between read lengths and write lengths, which might allow guest OS users to execute arbitrary code on the host OS by triggering use of an invalid index.

    • Update to 2.0.0+dfsg-2ubuntu1.15
    Published Updated
  6. CVE-2015-4106

    Not ratedEPSS 0.48%Fix available

    CVE-2015-4106

    QEMU does not properly restrict write access to the PCI config space for certain PCI pass-through devices, which might allow local x86 HVM guests to gain privileges, cause a denial of service (host crash), obtain sensitive information, or possibly have other unspecified impact via unknown vectors.

    • Update to 2.0.0+dfsg-2ubuntu1.13
    Published Updated
  7. CVE-2015-4103

    Not ratedEPSS 0.45%Fix available

    CVE-2015-4103

    Xen 3.3.x through 4.5.x does not properly restrict write access to the host MSI message data field, which allows local x86 HVM guest administrators to cause a denial of service (host interrupt handling confusion) via vectors related to qemu and accessing spanning multiple fields.

    • Update to 2.0.0+dfsg-2ubuntu1.13
    Published Updated
  8. CVE-2015-3456

    Not ratedEPSS 15.28%Public exploitFix available

    CVE-2015-3456

    The Floppy Disk Controller (FDC) in QEMU, as used in Xen 4.5.x and earlier and KVM, allows local guest users to cause a denial of service (out-of-bounds write and guest crash) or possibly execute arbitrary code via the (1) FD_CMD_READ_ID, (2) FD_CMD_DRIVE_SPECIFICATION_COMMAND, or other unspecified commands, aka VENOM.

    • Update to 2.0.0+dfsg-2ubuntu1.11
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →