p PatchFirst

PatchFirst · Latest vulnerabilities

samba vulnerabilities · Page 3

Vulnerabilities published for samba in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 57

  1. CVE-2016-2114

    Medium · CVSS 5.9EPSS 2.68%Fix available

    CVE-2016-2114

    The SMB1 protocol implementation in Samba 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not recognize the "server signing = mandatory" setting, which allows man-in-the-middle attackers to spoof SMB servers by modifying the client-server data stream.

    • Update to 2:4.3.8+dfsg-0ubuntu1
    Published Updated
  2. CVE-2016-2112

    Medium · CVSS 5.9EPSS 9.42%Fix available

    CVE-2016-2112

    The bundled LDAP client library in Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not recognize the "client ldap sasl wrapping" setting, which allows man-in-the-middle attackers to perform LDAP protocol-downgrade attacks by modifying the client-server data stream.

    • Update to 2:4.3.8+dfsg-0ubuntu1
    Published Updated
  3. CVE-2016-2111

    Medium · CVSS 6.3EPSS 2.9%Fix available

    CVE-2016-2111

    The NETLOGON service in Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2, when a domain controller is configured, allows remote attackers to spoof the computer name of a secure channel's endpoint, and obtain sensitive session information, by running a crafted application and leveraging the ability to sniff network traffic, a related issue to CVE-2015-0005.

    • Update to 2:4.3.8+dfsg-0ubuntu1
    Published Updated
  4. CVE-2016-2110

    Medium · CVSS 5.9EPSS 8.3%Fix available

    CVE-2016-2110

    The NTLMSSP authentication implementation in Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 allows man-in-the-middle attackers to perform protocol-downgrade attacks by modifying the client-server data stream to remove application-layer flags or encryption settings, as demonstrated by clearing the NTLMSSP_NEGOTIATE_SEAL or NTLMSSP_NEGOTIATE_SIGN option to disrupt LDAP security.

    • Update to 2:4.3.8+dfsg-0ubuntu1
    Published Updated
  5. CVE-2015-5370

    Medium · CVSS 5.9EPSS 19.1%Fix available

    CVE-2015-5370

    Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 does not properly implement the DCE-RPC layer, which allows remote attackers to perform protocol-downgrade attacks, cause a denial of service (application crash or CPU consumption), or possibly execute arbitrary code on a client system via unspecified vectors.

    • Update to 2:4.3.8+dfsg-0ubuntu1
    Published Updated
  6. CVE-2016-2118

    High · CVSS 7.5EPSS 37.18%Fix available

    CVE-2016-2118

    The MS-SAMR and MS-LSAD protocol implementations in Samba 3.x and 4.x before 4.2.11, 4.3.x before 4.3.8, and 4.4.x before 4.4.2 mishandle DCERPC connections, which allows man-in-the-middle attackers to perform protocol-downgrade attacks and impersonate users by modifying the client-server data stream, aka "BADLOCK."

    • Update to 2:4.3.8+dfsg-0ubuntu1
    Published Updated
  7. CVE-2016-0771

    Medium · CVSS 5.9EPSS 3.01%Fix available

    CVE-2016-0771

    The internal DNS server in Samba 4.x before 4.1.23, 4.2.x before 4.2.9, 4.3.x before 4.3.6, and 4.4.x before 4.4.0rc4, when an AD DC is configured, allows remote authenticated users to cause a denial of service (out-of-bounds read) or possibly obtain sensitive information from process memory by uploading a crafted DNS TXT record.

    • Update to 2:4.3.6+dfsg-1ubuntu1
    Published Updated
  8. CVE-2015-7560

    Medium · CVSS 6.5EPSS 12.94%Fix available

    CVE-2015-7560

    The SMB1 implementation in smbd in Samba 3.x and 4.x before 4.1.23, 4.2.x before 4.2.9, 4.3.x before 4.3.6, and 4.4.x before 4.4.0rc4 allows remote authenticated users to modify arbitrary ACLs by using a UNIX SMB1 call to create a symlink, and then using a non-UNIX SMB1 call to write to the ACL content.

    • Update to 2:4.3.6+dfsg-1ubuntu1
    Published Updated
  9. CVE-2015-8467

    High · CVSS 7.5EPSS 3.13%Fix available

    CVE-2015-8467

    The samldb_check_user_account_control_acl function in dsdb/samdb/ldb_modules/samldb.c in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3 does not properly check for administrative privileges during creation of machine accounts, which allows remote authenticated users to bypass intended access restrictions by leveraging the existence of a domain with both a Samba DC and a Windows DC, a similar issue to CVE-2015-2535.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated
  10. CVE-2015-7540

    High · CVSS 7.5EPSS 7.12%Fix available

    CVE-2015-7540

    The LDAP server in the AD domain controller in Samba 4.x before 4.1.22 does not check return values to ensure successful ASN.1 memory allocation, which allows remote attackers to cause a denial of service (memory consumption and daemon crash) via crafted packets.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated
  11. CVE-2015-5330

    High · CVSS 7.5EPSS 6.11%Fix available

    CVE-2015-5330

    ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles string lengths, which allows remote attackers to obtain sensitive information from daemon heap memory by sending crafted packets and then reading (1) an error message or (2) a database value.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated
  12. CVE-2015-5299

    Medium · CVSS 5.3EPSS 13.58%Fix available

    CVE-2015-5299

    The shadow_copy2_get_shadow_copy_data function in modules/vfs_shadow_copy2.c in Samba 3.x and 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3 does not verify that the DIRECTORY_LIST access right has been granted, which allows remote attackers to access snapshots by visiting a shadow copy directory.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated
  13. CVE-2015-5296

    Medium · CVSS 5.4EPSS 7.26%Fix available

    CVE-2015-5296

    Samba 3.x and 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3 supports connections that are encrypted but unsigned, which allows man-in-the-middle attackers to conduct encrypted-to-unencrypted downgrade attacks by modifying the client-server data stream, related to clidfs.c, libsmb_server.c, and smbXcli_base.c.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated
  14. CVE-2015-5252

    High · CVSS 7.2EPSS 13.27%Fix available

    CVE-2015-5252

    vfs.c in smbd in Samba 3.x and 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, when share names with certain substring relationships exist, allows remote attackers to bypass intended file-access restrictions via a symlink that points outside of a share.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated
  15. CVE-2015-3223

    Medium · CVSS 5.3EPSS 6.88%Fix available

    CVE-2015-3223

    The ldb_wildcard_compare function in ldb_match.c in ldb before 1.1.24, as used in the AD LDAP server in Samba 4.x before 4.1.22, 4.2.x before 4.2.7, and 4.3.x before 4.3.3, mishandles certain zero values, which allows remote attackers to cause a denial of service (infinite loop) via crafted packets.

    • Update to 2:4.3.3+dfsg-1ubuntu1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →