p PatchFirst

PatchFirst · Latest vulnerabilities

curl vulnerabilities · Page 2

Vulnerabilities published for curl in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 42

  1. CVE-2021-22898

    Low · CVSS 3.1EPSS 4.51%Fix available

    CVE-2021-22898

    curl 7.7 through 7.76.1 suffers from an information disclosure when the `-t` command line option, known as `CURLOPT_TELNETOPTIONS` in libcurl, is used to send variable=content pairs to TELNET servers. Due to a flaw in the option parser for sending NEW_ENV variables, libcurl could be made to pass on uninitialized data from a stack based buffer to the server, resulting in potentially revealing sensitive internal information to the server using a clear-text network protocol.

    • Update to 7.58.0-2ubuntu3.14
    Published Updated
  2. CVE-2021-22876

    Medium · CVSS 5.3EPSS 5.3%Fix available

    CVE-2021-22876

    curl 7.1.1 to and including 7.75.0 is vulnerable to an "Exposure of Private Personal Information to an Unauthorized Actor" by leaking credentials in the HTTP Referer: header. libcurl does not strip off user credentials from the URL when automatically populating the Referer: HTTP request header field in outgoing HTTP requests, and therefore risks leaking sensitive data to the server that is the target of the second HTTP request.

    • Update to 7.58.0-2ubuntu3.13
    Published Updated
  3. CVE-2020-8284

    Low · CVSS 3.7EPSS 3.9%Fix available

    CVE-2020-8284

    A malicious server can use the FTP PASV response to trick curl 7.73.0 and earlier into connecting back to a given IP address and port, and this way potentially make curl extract information about services that are otherwise private and not disclosed, for example doing port scanning and service banner extractions.

    • Update to 7.58.0-2ubuntu3.12
    Published Updated
  4. CVE-2019-3823

    Medium · CVSS 4.3EPSS 4.12%Fix available

    CVE-2019-3823

    libcurl versions from 7.34.0 to before 7.64.0 are vulnerable to a heap out-of-bounds read in the code handling the end-of-response for SMTP. If the buffer passed to `smtp_endofresp()` isn't NUL terminated and contains no character ending the parsed number, and `len` is set to 5, then the `strtol()` call reads beyond the allocated buffer. The read contents will not be returned to the caller.

    • Update to 7.58.0-2ubuntu3.6
    Published Updated
  5. CVE-2019-3822

    High · CVSS 7.1EPSS 12.87%Fix available

    CVE-2019-3822

    libcurl versions from 7.36.0 to before 7.64.0 are vulnerable to a stack-based buffer overflow. The function creating an outgoing NTLM type-3 header (`lib/vauth/ntlm.c:Curl_auth_create_ntlm_type3_message()`), generates the request HTTP header contents based on previously received data. The check that exists to prevent the local buffer from getting overflowed is implemented wrongly (using unsigned math) and as such it does not prevent the overflow from happening. This output data can grow larger than the local buffer if very large 'nt response' data is extracted from a previous NTLMv2 header provided by the malicious or broken HTTP server. Such

    • Update to 7.58.0-2ubuntu3.6
    Published Updated
  6. CVE-2018-16890

    Medium · CVSS 5.4EPSS 5.35%Fix available

    CVE-2018-16890

    libcurl versions from 7.36.0 to before 7.64.0 is vulnerable to a heap buffer out-of-bounds read. The function handling incoming NTLM type-2 messages (`lib/vauth/ntlm.c:ntlm_decode_type2_target`) does not validate incoming data correctly and is subject to an integer overflow vulnerability. Using that overflow, a malicious or broken NTLM server could trick libcurl to accept a bad length + offset combination that would lead to a buffer read out-of-bounds.

    • Update to 7.58.0-2ubuntu3.6
    Published Updated
  7. CVE-2018-14618

    High · CVSS 7.5EPSS 11.12%Fix available

    CVE-2018-14618

    curl before version 7.61.1 is vulnerable to a buffer overrun in the NTLM authentication code. The internal function Curl_ntlm_core_mk_nt_hash multiplies the length of the password by two (SUM) to figure out how large temporary storage area to allocate from the heap. The length value is then subsequently used to iterate over the password and generate output into the allocated storage buffer. On systems with a 32 bit size_t, the math to calculate SUM triggers an integer overflow when the password length exceeds 2GB (2^31 bytes). This integer overflow usually causes a very small buffer to actually get allocated instead of the intended very huge

    • Update to 7.58.0-2ubuntu3.3
    Published Updated
  8. CVE-2018-0500

    Critical · CVSS 9.8EPSS 6.35%Fix available

    CVE-2018-0500

    Curl_smtp_escape_eob in lib/smtp.c in curl 7.54.1 to and including curl 7.60.0 has a heap-based buffer overflow that might be exploitable by an attacker who can control the data that curl transmits over SMTP with certain settings (i.e., use of a nonstandard --limit-rate argument or CURLOPT_BUFFERSIZE value).

    • Update to 7.58.0-2ubuntu3.2
    Published Updated
  9. CVE-2018-1000301

    Critical · CVSS 9.1EPSS 5.92%Fix available

    CVE-2018-1000301

    curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

    • Update to 7.58.0-2ubuntu3.1
    Published Updated
  10. CVE-2018-1000300

    Critical · CVSS 9.8EPSS 4.7%Fix available

    CVE-2018-1000300

    curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

    • Update to 7.58.0-2ubuntu3.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →