p PatchFirst

PatchFirst · Latest vulnerabilities

ruby2.5 vulnerabilities · Page 2

Vulnerabilities published for ruby2.5 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 25

  1. CVE-2019-8324

    High · CVSS 8.8EPSS 3.22%Fix available

    CVE-2019-8324

    An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

    • Update to 2.5.1-1ubuntu1.2
    Published Updated
  2. CVE-2019-8320

    High · CVSS 7.4EPSS 4.19%Fix available

    CVE-2019-8320

    A Directory Traversal issue was discovered in RubyGems 2.7.6 and later through 3.0.2. Before making new directories or touching files (which now include path-checking code for symlinks), it would delete the target destination. If that destination was hidden behind a symlink, a malicious gem could delete arbitrary files on the user's machine, presuming the attacker could guess at paths. Given how frequently gem is run as sudo, and how predictable paths are on modern systems (/tmp, /usr, etc.), this could likely lead to data loss or an unusable system.

    • Update to 2.5.1-1ubuntu1.2
    Published Updated
  3. CVE-2018-16395

    Critical · CVSS 9.8EPSS 10.71%Fix available

    CVE-2018-16395

    An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before 2.6.0-preview3. When two OpenSSL::X509::Name objects are compared using ==, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of == will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

    • Update to 2.5.1-1ubuntu1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →