p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 2

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 35

  1. CVE-2024-33870

    Medium · CVSS 6.3EPSS 0.52%Fix available

    CVE-2024-33870

    An issue was discovered in Artifex Ghostscript before 10.03.1. There is path traversal (via a crafted PostScript document) to arbitrary files if the current directory is in the permitted paths. For example, there can be a transformation of ../../foo to ./../../foo and this will grant access if ./ is permitted.

    • Update to 9.55.0~dfsg1-0ubuntu5.7
    Published Updated
  2. CVE-2024-33869

    Medium · CVSS 5.3EPSS 0.45%Fix available

    CVE-2024-33869

    An issue was discovered in Artifex Ghostscript before 10.03.1. Path traversal and command execution can occur (via a crafted PostScript document) because of path reduction in base/gpmisc.c. For example, restrictions on use of %pipe% can be bypassed via the aa/../%pipe%command# output filename.

    • Update to 9.55.0~dfsg1-0ubuntu5.7
    Published Updated
  3. CVE-2024-29511

    High · CVSS 7.5EPSS 1.14%Fix available

    CVE-2024-29511

    Artifex Ghostscript before 10.03.1, when Tesseract is used for OCR, has a directory traversal issue that allows arbitrary file reading (and writing of error messages to arbitrary files) via OCRLanguage. For example, exploitation can use debug_file /tmp/out and user_patterns_file /etc/passwd.

    • Update to 9.55.0~dfsg1-0ubuntu5.9
    Published Updated
  4. CVE-2023-43115

    High · CVSS 8.8EPSS 5.96%Fix available

    CVE-2023-43115

    In Artifex Ghostscript through 10.01.2, gdevijs.c in GhostPDL can lead to remote code execution via crafted PostScript documents because they can switch to the IJS device, or change the IjsServer parameter, after SAFER has been activated. NOTE: it is a documented risk that the IJS server can be specified on a gs command line (the IJS device inherently must execute a command to start the IJS server).

    • Update to 9.55.0~dfsg1-0ubuntu5.5
    Published Updated
  5. CVE-2023-38559

    Medium · CVSS 5.5EPSS 0.43%Fix available

    Ghostscript: out-of-bound read in base/gdevdevn.c:1973 in devn_pcx_write_rle could result in dos

    A buffer overflow flaw was found in base/gdevdevn.c:1973 in devn_pcx_write_rle() in ghostscript. This issue may allow a local attacker to cause a denial of service via outputting a crafted PDF file for a DEVN device with gs.

    • Update to 9.55.0~dfsg1-0ubuntu5.4
    Published Updated
  6. CVE-2023-28879

    Critical · CVSS 9.8EPSS 6.34%Fix available

    CVE-2023-28879

    In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written.

    • Update to 9.55.0~dfsg1-0ubuntu5.2
    Published Updated
  7. CVE-2022-2085

    Medium · CVSS 5.5EPSS 1.41%Fix available

    CVE-2022-2085

    A NULL pointer dereference vulnerability was found in Ghostscript, which occurs when it tries to render a large number of bits in memory. When allocating a buffer device, it relies on an init_device_procs defined for the device that uses it as a prototype that depends upon the number of bits per pixel. For bpp > 64, mem_x_device is used and does not have an init_device_procs defined. This flaw allows an attacker to parse a large number of bits (more than 64 bits per pixel), which triggers a NULL pointer dereference flaw, causing an application to crash.

    • Update to 9.55.0~dfsg1-0ubuntu5.1
    Published Updated
  8. CVE-2021-3781

    Critical · CVSS 9.9EPSS 83.91%Fix available

    CVE-2021-3781

    A trivial sandbox (enabled with the `-dSAFER` option) escape flaw was found in the ghostscript interpreter by injecting a specially crafted pipe command. This flaw allows a specially crafted document to execute arbitrary commands on the system in the context of the ghostscript interpreter. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 9.54.0~dfsg1-0ubuntu2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →