p PatchFirst

ALPINE-CVE-2025-65082

ALPINE-CVE-2025-65082

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.

CVSS 6.5 · Medium · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache2 Alpine:v3.20

    Affected ranges
    • ECOSYSTEM: < 2.4.66-r0

    Update to 2.4.66-r0

  • apache2 Alpine:v3.21

    Affected ranges
    • ECOSYSTEM: < 2.4.66-r0

    Update to 2.4.66-r0

  • apache2 Alpine:v3.22

    Affected ranges
    • ECOSYSTEM: < 2.4.66-r0

    Update to 2.4.66-r0

  • apache2 Alpine:v3.23

    Affected ranges
    • ECOSYSTEM: < 2.4.66-r0

    Update to 2.4.66-r0

  • apache2 Alpine:v3.24

    Affected ranges
    • ECOSYSTEM: < 2.4.66-r0

    Update to 2.4.66-r0

Original sources

Check your server →