p PatchFirst

PatchFirst · Latest vulnerabilities

libvpx vulnerabilities · Page 2

Vulnerabilities published for libvpx in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 31

  1. CVE-2016-3881

    Medium · CVSS 5.5EPSS 0.73%Fix available

    CVE-2016-3881

    The decoder_peek_si_internal function in vp9/vp9_dx_iface.c in libvpx in mediaserver in Android 4.x before 4.4.4, 5.0.x before 5.0.2, 5.1.x before 5.1.1, 6.x before 2016-09-01, and 7.0 before 2016-09-01 allows remote attackers to cause a denial of service (buffer over-read, and device hang or reboot) via a crafted media file, aka internal bug 30013856.

    • Update to 1.6.1-1
    Published Updated
  2. CVE-2016-1621

    Critical · CVSS 9.8EPSS 5.9%Fix available

    CVE-2016-1621

    libvpx in mediaserver in Android 4.x before 4.4.4, 5.x before 5.1.1 LMY49H, and 6.0 before 2016-03-01 allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted media file, related to libwebm/mkvparser.cpp and other files, aka internal bug 23452792.

    • Update to 1.6.1-1
    Published Updated
  3. CVE-2015-1258

    Not ratedEPSS 2.38%Fix available

    CVE-2015-1258

    Google Chrome before 43.0.2357.65 relies on libvpx code that was not built with an appropriate --size-limit value, which allows remote attackers to trigger a negative value for a size field, and consequently cause a denial of service or possibly have unspecified other impact, via a crafted frame size in VP9 video data.

    • Update to 1.4.0-4
    Published Updated
  4. CVE-2014-1578

    Not ratedEPSS 4.02%Fix available

    CVE-2014-1578

    The get_tile function in Mozilla Firefox before 33.0, Firefox ESR 31.x before 31.2, and Thunderbird 31.x before 31.2 allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or possibly execute arbitrary code via WebM frames with invalid tile sizes that are improperly handled in buffering operations during video playback.

    • Update to 1.3.0-3
    Published Updated
  5. CVE-2012-0823

    Not ratedEPSS 2.5%Fix available

    CVE-2012-0823

    VP8 Codec SDK (libvpx) before 1.0.0 "Duclair" allows remote attackers to cause a denial of service (application crash) via (1) unspecified "corrupt input" or (2) by "starting decoding from a P-frame," which triggers an out-of-bounds read, related to "the clamping of motion vectors in SPLITMV blocks".

    • Update to 1.0.0-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →