p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 6

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 166

  1. CVE-2018-10194

    High · CVSS 7.8EPSS 2.05%Fix available

    CVE-2018-10194

    The set_text_distance function in devices/vector/gdevpdts.c in the pdfwrite component in Artifex Ghostscript through 9.22 does not prevent overflows in text-positioning calculation, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.

    • Update to 9.22~dfsg-2.1
    Published Updated
  2. CVE-2017-11714

    High · CVSS 7.8EPSS 2.3%Fix available

    CVE-2017-11714

    psi/ztoken.c in Artifex Ghostscript 9.21 mishandles references to the scanner state structure, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PostScript document, related to an out-of-bounds read in the igc_reloc_struct_ptr function in psi/igc.c.

    • Update to 9.22~dfsg-1
    Published Updated
  3. CVE-2017-9835

    High · CVSS 7.8EPSS 2.79%Fix available

    CVE-2017-9835

    The gs_alloc_ref_array function in psi/ialloc.c in Artifex Ghostscript 9.21 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted PostScript document. This is related to a lack of an integer overflow check in base/gsalloc.c.

    • Update to 9.22~dfsg-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →