p PatchFirst

PatchFirst · Latest vulnerabilities

openssl vulnerabilities · Page 14

Vulnerabilities published for openssl in the last 30 days: 13. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 289

  1. CVE-2008-0166

    High · CVSS 7.5EPSS 70.72%Public exploitFix available

    CVE-2008-0166

    OpenSSL 0.9.8c-1 up to versions before 0.9.8g-9 on Debian-based operating systems uses a random number generator that generates predictable numbers, which makes it easier for remote attackers to conduct brute force guessing attacks against cryptographic keys.

    • Update to 0.9.8g-9
    Published Updated
  2. CVE-2007-5135

    Not ratedEPSS 16.06%Fix available

    CVE-2007-5135

    Off-by-one error in the SSL_get_shared_ciphers function in OpenSSL 0.9.7 up to 0.9.7l, and 0.9.8 up to 0.9.8f, might allow remote attackers to execute arbitrary code via a crafted packet that triggers a one-byte buffer underflow. NOTE: this issue was introduced as a result of a fix for CVE-2006-3738. As of 20071012, it is unknown whether code execution is possible.

    • Update to 0.9.8e-9
    Published Updated
  3. CVE-2006-2940

    Not ratedEPSS 5.1%Fix available

    CVE-2006-2940

    OpenSSL 0.9.7 before 0.9.7l, 0.9.8 before 0.9.8d, and earlier versions allows attackers to cause a denial of service (CPU consumption) via parasitic public keys with large (1) "public exponent" or (2) "public modulus" values in X.509 certificates that require extra time to process when using RSA signature verification.

    • Update to 0.9.8c-2
    Published Updated
  4. CVE-2006-4339

    Not ratedEPSS 5.09%Fix available

    CVE-2006-4339

    OpenSSL before 0.9.7, 0.9.7 before 0.9.7k, and 0.9.8 before 0.9.8c, when using an RSA key with exponent 3, removes PKCS-1 padding before generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents OpenSSL from correctly verifying X.509 and other certificates that use PKCS #1.

    • Update to 0.9.8b-3
    Published Updated
  5. CVE-2005-2969

    Not ratedEPSS 4.87%Fix available

    CVE-2005-2969

    The SSL/TLS server implementation in OpenSSL 0.9.7 before 0.9.7h and 0.9.8 before 0.9.8a, when using the SSL_OP_MSIE_SSLV2_RSA_PADDING option, disables a verification step that is required for preventing protocol version rollback attacks, which allows remote attackers to force a client and server to use a weaker protocol than needed via a man-in-the-middle attack.

    • Update to 0.9.8-3
    Published Updated
  6. CVE-2003-0078

    Not ratedEPSS 13.72%Public exploitFix available

    CVE-2003-0078

    ssl3_get_record in s3_pkt.c for OpenSSL before 0.9.7a and 0.9.6 before 0.9.6i does not perform a MAC computation if an incorrect block cipher padding is used, which causes an information leak (timing discrepancy) that may make it easier to launch cryptographic attacks that rely on distinguishing between padding and MAC verification errors, possibly leading to extraction of the original plaintext, aka the "Vaudenay timing attack."

    • Update to 0.9.7a-1
    Published Updated
  7. CVE-2004-0112

    Not ratedEPSS 10.42%Fix available

    CVE-2004-0112

    The SSL/TLS handshaking code in OpenSSL 0.9.7a, 0.9.7b, and 0.9.7c, when using Kerberos ciphersuites, does not properly check the length of Kerberos tickets during a handshake, which allows remote attackers to cause a denial of service (crash) via a crafted SSL/TLS handshake that causes an out-of-bounds read.

    • Update to 0.9.7d-1
    Published Updated
  8. CVE-2002-1568

    Not ratedEPSS 2.8%Fix available

    CVE-2002-1568

    OpenSSL 0.9.6e uses assertions when detecting buffer overflow attacks instead of less severe mechanisms, which allows remote attackers to cause a denial of service (crash) via certain messages that cause OpenSSL to abort from a failed assertion, as demonstrated using SSLv2 CLIENT_MASTER_KEY messages, which are not properly handled in s2_srvr.c.

    • Update to 0.9.6g-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →